Opened 10 years ago

Closed 6 years ago

#365 closed defect (fixed)

Memory below 16 Mb

Reported by: eco Owned by:
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

e-co:

  • Low memory

Pasha will try reduce memory for ACPI log, to free memory for OS and drivers (below 16 Mb)

how to change the size of log? for example ACPI.PSD /LOGSIZE:Kbytes ?

Change History (8)

comment:1 Changed 10 years ago by ecsnl

It might be not needed to work on this since RC 6a we use the earlymeminit=true. Then this does not need to be done.

comment:2 Changed 10 years ago by eco

e-co:

Pasha:

available memory: 16 mb log occupies: 1 Mb

other idea: start generation of log from acpi daemon.

comment:3 Changed 10 years ago by eco

e-co:

"+"

some monthes ago Pasha was making efforts to minimize the usage of low memory, its fragmentation, and he reported about positive results.

"+" ACPI is a heavy driver, NTFS is heavy, UNIAUD is heavy. SNAP is heavy. Users were reporting in the past, if disable NTFS then system starts booting. For other users: if disable uniaud then acpi starts boot, etc.

I can't show references.

"-"

Pasha, no, ignore this offering. i reduced the size of JFS cache from 200 Mb to 90 Mb. This helped to SNAP.

comment:4 Changed 10 years ago by ecsnl

The JFS cache can be the cause of certain low memory buffers conditions. But is the 16 MB buffer not the biggest problem ? Thats why earlymeminit=true was introduced with RC 6a.

comment:5 Changed 10 years ago by pasha

This ticket is wrong for acpi

comment:6 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Release version 3.16

comment:7 Changed 9 years ago by stevenhl

  • Owner pasha deleted

comment:8 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.