Opened 11 years ago

Closed 9 years ago

#320 closed defect (unknown)

Machine hangs on acpideamon, Thinkpad T42

Reported by: ecsnl Owned by:
Priority: major Milestone: Release version 3.14
Component: ACPI PSD Version: 3.13
Keywords: Cc:

Description

When ACPIDEAMON is loaded via the config.sys the system PMSHELL never loads.

This is done with ACPI 3.11 with new Intel CA code this test. With the debug version of the ACPI.PSD a lot of text is shown on the screen and a mention that a buffer is exhausted. It seems in hangs in in loop somewhere. Looking at the error messages it seems the buffer to store the error messages for acpica$ is even nog to small.

Attached is the output of acpica$

Attachments (7)

dump.zip (29.4 KB) - added by ecsnl 11 years ago.
IASL.ZIP (48.4 KB) - added by ecsnl 11 years ago.
T42.LOG (11.4 KB) - added by ecsnl 11 years ago.
acpi_battery_acpica$.zip (29.5 KB) - added by ecsnl 11 years ago.
acpi_debug_kernel_int3_20081125.txt (7.3 KB) - added by stevenhl 11 years ago.
acpi_demon_trapE_20081127.txt (8.4 KB) - added by stevenhl 11 years ago.
acpi ticket 320 suspend hang 20081202d.txt (4.0 KB) - added by stevenhl 11 years ago.

Download all attachments as: .zip

Change History (38)

Changed 11 years ago by ecsnl

Changed 11 years ago by ecsnl

comment:1 Changed 11 years ago by ecsnl

Taking out APM.ADD made it boot to the PMSHELL and all the debug output is gone. The t42.log was created with ACPI 3.11 with new ACPICA code and stack increase, from zip file :File: ACPI12112008.ZIP 536 KB 12-11-08 11:48:00

Output is from type ACPICA$

Changed 11 years ago by ecsnl

comment:2 Changed 11 years ago by ecsnl

output of latest acpibattery.exe

Show ACPI battery state Found Smart Battery "BAT0" Battery status 0x1f =========== Battery design =============== Power Unit: capacity is mW , charge/discharge rate is mW 1 Design capacity 47520 mW 1 Last full charge capacity 22410 mW 1 Battery technology 1 1 Design voltage 10800 mV 1 Design capacity of warning 1120 mW 1 Design capacity of low 200 mW 1 Baterry granularity between low and warning 1 mW 1 Baterry granularity between warning and high 1 mWh 3 ModelNumber?: "IBM-08K8193" 16 bytes "49424d2d30384b383139330000000000" 3 SerialNumber?: " 2655" 6 bytes 20 3 Battery type: "LION"5 bytes 3 OEM info: "SANYO" 16 =========== Battery Status =============== Buttery is charging Buttery is low critical energy state 1 Battery present rate 29042 1 Battery remaining capacity 0 1 Battery present voltage 11937 mV Found Smart Battery "BAT1" Battery status 0x0 =========== Battery design =============== Power Unit: capacity is mW , charge/discharge rate is mW Unknown design capacity Unknown last full charge capacity 1 Battery technology 1 1 Design voltage 10800 mV 1 Design capacity of warning 0 mW 1 Design capacity of low 0 mW 1 Baterry granularity between low and warning 1 mW 1 Baterry granularity between warning and high 1 mWh 2 ModelNumber?: "" 0 bytes "" 2 SerialNumber?: "" 0 bytes 0 2 Battery type: ""0 bytes 2 OEM info: "" 0 =========== Battery Status =============== Buttery is low critical energy state 1 Battery present rate 0 1 Battery remaining capacity 0 1 Battery present voltage 0 mV Status 0x0 0 - No error

comment:3 Changed 11 years ago by ecsnl

Here is output of new acpibattery.exe from 13/11/2008

how ACPI battery state Found Smart Battery "BAT0" Battery status 0x1f =========== Battery design =============== Power Unit: capacity is mW , charge/discharge rate is mW 1 Design capacity 47520 mW 1 Last full charge capacity 22410 mW 1 Battery technology 1 1 Design voltage 10800 mV 1 Design capacity of warning 1120 mW 1 Design capacity of low 200 mW 1 Baterry granularity between low and warning 1 mW 1 Baterry granularity between warning and high 1 mWh 3 ModelNumber?: "IBM-08K8193" 16 bytes "49424d2d30384b383139330000000000" 3 SerialNumber?: " 2655" 6 bytes 20 3 Battery type: "LION"5 bytes 3 OEM info: "SANYO" 16 =========== Battery Status =============== Buttery is charging 1 Battery present rate 6030 1 Battery remaining capacity 18600 1 Battery present voltage 12460 mV Remaining Battery Life: 3.084577 h Remaining Battery Percentage: 82 Found Smart Battery "BAT1" Battery status 0x0 =========== Battery design =============== Power Unit: capacity is mW , charge/discharge rate is mW Unknown design capacity Unknown last full charge capacity 1 Battery technology 1 1 Design voltage 10800 mV 1 Design capacity of warning 0 mW 1 Design capacity of low 0 mW 1 Baterry granularity between low and warning 1 mW 1 Baterry granularity between warning and high 1 mWh 2 ModelNumber?: "" 0 bytes "" 2 SerialNumber?: "" 0 bytes 0 2 Battery type: ""0 bytes 2 OEM info: "" 0 =========== Battery Status =============== Buttery is low critical energy state 1 Battery present rate 0 1 Battery remaining capacity 0 1 Battery present voltage 0 mV Remaining Battery Life: 3.084577 h Remaining Battery Percentage: 82 Found AC "AC" AC status is: 1 Status 0x0 0 - No error

comment:4 Changed 11 years ago by ecsnl

FIle created after running latest acpibattery

Changed 11 years ago by ecsnl

comment:5 Changed 11 years ago by eco

e-co:

I can't repeat this problem

http://svn.netlabs.org/acpi/ticket/323

1) Let's compare BIOS version

2) Can you test with RESOURCE.SYS distributed with ACPI?

3) try simple test: http://ecomstation.ru/projects/acpitools/download/acpi-test.cmd

comment:6 Changed 11 years ago by ecsnl

Testing with the resource.sys from ACPI can you give me technical details why it should matter to use the build from ACPI.ZIP or the patched version. The only thing it does different it that it looks for previous.acp instead previous.dat. That way enabling full hardware detection always.

And the tests the script run I looked it does errors are not present. Its a standard eCS 2.0 RC install.

comment:7 Changed 11 years ago by stevenhl

acpi_debug_kernel_int3_20081125.txt shows the code that that results in a kernel int 3 on a T42 with the acpi.psd v3.11 built on 11 Nov 2008. The int 3 is caused by spin lock contention.

comment:8 Changed 11 years ago by pasha

I saying before. If you have int 3 in IRQRouter, I interested in airqi pointer for this IRQ, which you can look in ebx. So db ebx is full info for me in this case.

Changed 11 years ago by stevenhl

comment:9 Changed 11 years ago by stevenhl

I have updated acpi_debug_kernel_int3_20081125.txt with the requesting info.

FWIW, the logs already tell you which interrupt is being serviced. See InterruptLevel? and CurrIntLevel?. These tell you the nesting and the interrupt that is being serviced.

For those reading along, interrupt 8 is the clock interrupt. The interrupt occurred because the KernVMAlloc or something it called enabled interrupts which ACPICA held a spinlock.

The debug kernel version of IntIRQRouter checks if spinlocks are owned when it is called and considers this a fatal error.

comment:10 Changed 11 years ago by ecsnl

I do not know what was modified in ACPI 3.13. But the crash with the debug kernel and APM.ADD is now gone so what was fixed is unclear to me. But the system still freezes solid on ACPIDEAMON loading.

Does not matter if its done via CONFIG.SYS or loaded when PMSHELL is loaded and then load from command line.

The debug kernel is loaded and it kicks (as system is frozen). I don't have the docking station handy right now I will hook that up tomorow so Pasha and Steve can look at this. But its clear something is still wrong.

comment:11 Changed 11 years ago by eco

Pasha asked:

? do you have acpid.cfg -> IdleState?=C3

Please try HLT or C1

comment:12 Changed 11 years ago by ecsnl

Its set to default setting in file HLT its set to.

comment:13 Changed 11 years ago by eco

yes,

HLT is default for all eComStation computers..

hmm

comment:14 Changed 11 years ago by ecsnl

The internal build of ACPI 3.13 does not have SYM iles yt so I had to run the kernel debugger with the older symfiles.

The moment acpideamon.exe loads on the terminal I get this output:

##r Trap 14 (0EH) - Page Fault 0002, Not Present, Write Access, Supervisor eax=00000000 ebx=00000000 ecx=00000001 edx=00000000 esi=ffe68700 edi=00000000 eip=f9ad1082 esp=ffe4ffcc ebp=ffe4ffe4 iopl=0 rf -- -- nv up di ng nz na pe nc cs=0178 ss=1520 ds=0170 es=0170 fs=0000 gs=0000 cr2=00000380 cr3=00225000 p=00 0178:f9ad1082 c7838003000000000000 mov dword ptr [ebx+00000380],00000000

ds:00000380=invalid

comment:15 Changed 11 years ago by ecsnl

With SMP kernel 104a loaded the output of acpi.psd and debugger kernel Pasha concludes:

"*[Pasha]* you have't LocalAPIC address in acpi table "

Test with UNI kernel failed seems problem on system not ACPI related. Problem with doscall1.dll no clue why.

comment:16 Changed 11 years ago by ecsnl

Pasha suggested I install the UNI kernel. The crashed happened with the SMP kernel installed. I don't know why the system crashes. I have installed the _W4 version of doscall1.dll I will try on monday.

Changed 11 years ago by stevenhl

comment:17 Changed 11 years ago by stevenhl

Roderick asked me to look at the trap E in acpidaemon. See acpi_demon_trapE_20081127.txt for an analysis. Basically the code is confused and is attempting to dereference a null pointer. The code is not yet in the svn repositiory, so I can not tell if the is a missing null pointer check or a table initialization problem.

comment:18 Changed 11 years ago by pasha

  • Milestone changed from Release version 3.12 to Release version 3.13
  • Version changed from 3.11 to 3.13

Fixed, ACPI29112008.ZIP at mensys ftp

comment:19 Changed 11 years ago by ecsnl

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed with ACPI29112008.ZIP. Request to release this version as ACPI 3.14 with retail build.

comment:20 Changed 11 years ago by stevenhl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Changed 11 years ago by stevenhl

comment:21 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from reopened to closed

the hang on boot is fixed.

problem was: Mensys switched to testing of SMP kernel too late.

ACPI 3.14:

  • fix trap with SMP kernel and absent MADT

Suspend/resume - please create other ticket, wait when R60 starts working

comment:22 Changed 11 years ago by ecsnl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ticket 320, 344 and 353 are very interesting!

What I did not report in this ticket was that I had the same problem as Alex Taylor had. When I loaded acpideamon I could not create memory dump to a partition. The moment I would try the system would hang in a loop forever. A memory dump without acpideamon loaded worked!

Interesting this problem Alex also has. It seems loading the acpideamon wrecks something on ring 0...

comment:23 Changed 11 years ago by eco

e-co:

Tickets 320, 344 and 353 relate to ACPI daemon, but not equal.

Pasha:

ENG:

ACPI daemon is very critical application, it starts 5 threads in Ring-0, events start to process. Event = Interrupts, ACPI CA code. So troubles are possible.

RUS:

еще раз, acpidaemon запускает аж 5м штук тредов в R0. по ему начинает отработка евентов... а эвенты это перерывания и acpi ca.

comment:24 Changed 11 years ago by ecsnl

Yes I know that. I don't have enough information but I see so many failures with this acpideamon and it does not matter if you load it from config.sys or when PMSHELL is loaded.

What I'm saying it that everything (Including Rudiger Ihle his testing at Warpstock) is al pointing somehow to some code that deals with the amount of batteries in the system. With RC 5 these problems where not that big yet as far I can tell and then we also installed ACPIDEAMON.EXE.

comment:25 follow-up: Changed 11 years ago by ecsnl

Infact I can't remember these changes being there.

comment:26 in reply to: ↑ 25 Changed 11 years ago by ecsnl

Replying to ecsnl:

Infact I can't remember these changes being there.

I ment to type that I can't remember that there where that many problems with RC 5 and the acpideamon.

comment:27 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.13 to Release version 3.15

comment:28 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:29 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:30 Changed 11 years ago by pasha

  • Owner pasha deleted
  • Status changed from reopened to new

comment:31 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.14
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.