Opened 10 years ago

Closed 10 years ago

#288 closed defect (fixed)

hang T61 at screen01.sys w/ acpi v3.10

Reported by: ecs273 Owned by: pasha
Priority: major Milestone: Release version 3.12
Component: ACPI PSD Version: 3.10
Keywords: Cc:

Description

This is about the same as 'resolved' ticket #105. Using clean install of rc5, acpi v3.10 and apm v1.25. When booting my thinkpad T61, the system stops at screen01.sys being displayed (alt-F2) and never proceeds. I have waited as long as 10 minutes. Attached are acpi log files from v3.07 & 3.09, a hardware log and acpiDaemon log. I also include resource.sys just in case it is not the right one.

Attachments (3)

noname00.zip (40.2 KB) - added by ecs273 10 years ago.
reported by ecs273
T61hang-1.JPG (46.2 KB) - added by ecs273 10 years ago.
testcase acpi hang at screen01.sys
noname01.zip (176.3 KB) - added by ecs273 10 years ago.
User 'ecs273' log files

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by ecs273

reported by ecs273

comment:1 follow-ups: Changed 10 years ago by eco

Please try the latest special build of ACPI,

How to download special build:

http://ecomstation.ru/projects/acpitools/?action=testcase

comment:2 in reply to: ↑ 1 Changed 10 years ago by ecs273

Replying to eco:

Please try the latest special build of ACPI,

How to download special build:

http://ecomstation.ru/projects/acpitools/?action=testcase

I don't see any files with the name 'testcase' in the ACPI file section at betazone. The most recent files I see are from July which are for apci v3.10.

Jon

Changed 10 years ago by ecs273

testcase acpi hang at screen01.sys

comment:3 in reply to: ↑ 1 Changed 10 years ago by ecs273

Replying to eco:

Please try the latest special build of ACPI,

How to download special build:

http://ecomstation.ru/projects/acpitools/?action=testcase

OK, found the testcase. Applied acpi-t-291207.zip This causes same problem as v3.10, system hangs at screen01.sys Removed os2logo and same problem. t61hang-1.jpg screenshot attached.

Rgds, Jon

comment:4 follow-ups: Changed 10 years ago by pasha

Need use debug acpi version. This version _must_ write to screen

comment:5 in reply to: ↑ 4 Changed 10 years ago by ecs273

Replying to pasha:

Need use debug acpi version. This version _must_ write to screen

Do you mean a debug version of acpi-t-291207.zip? - there is no debug folder in that archive, I installed the files in that archive and since they contain the symbol files I thought it was a debug version. Or do you mean debug version of v3.10? A few days ago I tried the debug version of v3.10 and it did not proceed past the screen01.sys (I did have os2logo installed at that time).

I need to know exactly which version you want me to try. I assume the all debug versions write to the screen, correct?

Rgds, Jon

comment:6 in reply to: ↑ 4 Changed 10 years ago by ecs273

Replying to pasha:

Need use debug acpi version. This version _must_ write to screen

New info for you!

Installed v3.10 debug. Removed my usb mouse. Now boot completes to desktop. I have attached (noname01) various logs, iasl output, my config.sys, and a jpeg of the debug error when the mouse is attached. The error is continuously scrolling of message "emm wait lock x" where x increments forever until power cycled.

Changed 10 years ago by ecs273

User 'ecs273' log files

comment:7 Changed 10 years ago by ecs273

Installing v3.11 FIXED this problem and you can consider it resolved.

THANKS, Jon

comment:8 Changed 10 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.