Opened 8 years ago

Closed 7 years ago

#28 closed defect (fixed)

ACPI 3.01 and 3.0 trap on IBM Xseries 345

Reported by: Roderick Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.0
Keywords: Cc:

Description

With ACPI 3.0 and 3.01 the server traps.

As requested a ticket on this bug.

ACPI never realy worked on this machine, HOWEVER, turned out a BIOS upgrade was required! Its an IBM Xseries 345 with 2 Xeon CPU's http://en.ecomstation.ru/hardware.php?action=item&id=1194

ACPI 2.22 worked mostly however 3.0 and 3.01 trap the server.

This is the update that was required: http://www-304.ibm.com/jct01004c/systems/support/supportsite.wss/docdisp lay?brandind=5000008&lndocid=MIGR-43902 (Maybe its usefull since the diskette images contains the BIOS images etc).

Loading the _W4 kernel and ACPI 3.01 without any switches in the config.sys results in:

Exception in module ACPI

Trap 000e ERRCD=0002 ERACC= ERLIM=* EAX=00000000 EBX=31494350 ECX=f9f10ee0 EDX=00000000 ESI=00000002 EDU=f9f10ee0 EBP=ffdea924 GLF=00013246 CS:EIP=0168:f9f2b708 CSACC=c09b CSLIM=FFFFFFFF SS:ESP=1550:ffdea8e0 SSACC=c093 SSLIM=FFFFFFFF DS=0160 DSACC=c0f3 DSLIM=ffffffff CR0=80010013 ES=0160 ESACC=c0f3 ESLIM=ffffffff CR0=0000000c FS=0000 FSACC= FSLIM= GS=0000 GSACC= GSLIM=

The system detected an internal processing error at location

##0168:ffff1da1f - 000e:ca1f 6000, 9084

0886090f Internal revision 14.104a_W4

I can NOT make a memory dump. CTRL ALT F10 does not respond, server hangs solid. This trap occurs instantly when the machine starts up and loads the PSD.

I will open another ticket for the problem with the trace tool.

Change History (1)

comment:1 Changed 7 years ago by pasha

  • Resolution set to fixed
  • Status changed from new to closed

Try 3.03 and reopen ticket if problem is here. If reopen add acpi.log from any boot. Mean as you can boot with acpi - Uni, SMP e.t.c.

3.3 has increase count of supports IO APIC

Note: See TracTickets for help on using tickets.