Opened 11 years ago

Closed 11 years ago

#27 closed defect (fixed)

ACPI 3.0 issues

Reported by: Eugene Gorbunoff Owned by: pasha
Priority: major Milestone:
Component: ACPI PSD Version: 3.0
Keywords: Cc:

Description

I've installed ACPI 3.0 using the WPI release to update my eCS 2.0 RC1 on my Thinkpad T42p.

I had been getting over 2 hours when on battery using the older ACPI releases. Now I get about 1 hour and 15 minutes. As before the power object shows "Maximum Performance" whether on AC or Battery.

Power off works, but Suspend caused a TRAP D error. see attached PNG

One good thing is that I've been running for a couple days now and the Beer battery widget on eCenter hasn't caused eCenter to hang. Not sure if that is just luck or not.

Attachments (1)

SuspendTrapDACPI300.png (84.2 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by anonymous

comment:1 Changed 11 years ago by Eugene Gorbunoff

2 Mark Dodel:

"Now I get about 1 hour and 15 minutes. "

Check AcpiD.cfg -> IdleState? = HLT

Try change to C2 or C3

comment:2 Changed 11 years ago by Madodel

Check AcpiD.cfg -> IdleState?? = HLT

Try change to C2 or C3

Tried both C2 and C3, same TRAP.

Mark

comment:3 Changed 11 years ago by madodel

Tried ACPI 3.01. Boot kept hanging on smstart.exe. I booted to maintenance partition and changed idlestate= back to HLT and it now boots, but suspend does nothing now. No more TRAP but it doesn't even try to go into Suspend.

I see in Eugene's announcement of 3.01 that Panorama VESA video driver is required. I am using the last SNAP Pro. Could that be the problem?

Mark

comment:4 Changed 11 years ago by pasha

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 3.1 version

Note: See TracTickets for help on using tickets.