Opened 11 years ago

Closed 11 years ago

#29 closed defect (fixed)

Roderick

Reported by: anonymous Owned by: anonymous
Priority: major Milestone:
Component: ACPI PSD Version: 3.0
Keywords: Cc:

Description

As requested a ticket on this bug (compared to the email I send to the mailing list I provide more clarification in this ticket.

ACPI never really worked on this machine, HOWEVER, turned out a BIOS upgrade was required! Its an IBM Xseries 345 with 2 Xeon CPU's http://en.ecomstation.ru/hardware.php?action=item&id=1194

This is the update that was required: http://www-304.ibm.com/jct01004c/systems/support/supportsite.wss/docdisp lay?brandind=5000008&lndocid=MIGR-43902 (Maybe its usefull since the diskette images contains the BIOS images etc).

ACPI 2.22 worked just fine on this machine. With the /SMP switch the two Xeon 2.4 Ghz worked. No other switches where used. Turning on hyperthreading on resulted even in 4 CPU's in they eCenter.

However one problem occured that is an error in ACPI. This error does NOT occur when I install OS2APIC.PSD or have ACPI.PSD loaded and switch off(!) hyperthreading support in the BIOS.

This problem was tested on eComStation 2.0 RC 1 ACPI 2.22, SMP kernel 104a.

The attached script from Steve Levine was used to tested the process dump (note it has fixed paths in it Steve still needs to do some cleaning up).

*Start 4os2

Then run pdump -i 4os2

Choose F and S

Then choose to perform a dump.

I can not produce a memory dump. What happens is that eComStation freezes and the server then even automaticly reboots. The management CPU does this! So something seems to going seriously wrong!!! The BIOS has no entry about this reboot. So there is no trap screen.

Doing the same dump WITH OS2APIC.PSD installed from IBM installed and running the dump utility it all works fine.

So I have to conclude this is bug in ACPI.PSD. Don't know what else it could be. Standard VGA driver installed and only /SMP in config.sys.

I also just tried to install ACPI.PSD 3.0 /3.01 but this results in another problem. It traps at startup at the moment the PSD is loaded. I just opened another ticket for that.

I ran the same test on an Intel Duo core with ACPI.PSD with the /SMP switch installed and this worked.

So a bit puzzled :-)

Attachments (1)

PDUMP.CMD (6.8 KB) - added by roderick 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by roderick

comment:1 Changed 11 years ago by pasha

  • Owner changed from pasha to anonymous
  • Status changed from new to assigned

SMP can don't show trap to you. If you use /R for acpi.psd - you don't see trap. For getting trap need:

  • install debug kernel
  • put cable to comport
  • do your doing
  • see trap in terminal

comment:2 Changed 11 years ago by pasha

  • Resolution set to fixed
  • Status changed from assigned to closed

Try with 3.3 and reopen ticket if have problem. See #28 for detail

Note: See TracTickets for help on using tickets.