Opened 12 years ago

Closed 8 years ago

#254 closed defect (fixed)

Previous.dat missing data on T60

Reported by: ecsnl Owned by:
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.09
Keywords: Cc:

Description (last modified by Steven Levine)

Ticket added by Roderick Klein.

With ACPI not loaded on my T60, the output of PCIBUS.SNP is not included in previous.dat (see attached files).

With ACPI loaded this information is not there.

What's the cause of this?

Roderick Klein

Attachments (3)

PREVIOUS.DAT (355 bytes) - added by Chuck McKinnis 12 years ago.
previous_correct.dat (3.5 KB) - added by Chuck McKinnis 12 years ago.
resource.sys (54.1 KB) - added by ecsnl 12 years ago.

Download all attachments as: .zip

Change History (20)

Changed 12 years ago by Chuck McKinnis

Attachment: PREVIOUS.DAT added

Changed 12 years ago by Chuck McKinnis

Attachment: previous_correct.dat added

comment:1 Changed 12 years ago by Steven Levine

Description: modified (diff)

comment:2 Changed 12 years ago by Steven Levine

Description: modified (diff)
Summary: Previous.dat misses dataPrevious.dat missing data on T60

comment:3 Changed 12 years ago by Steven Levine

Description: modified (diff)

comment:4 Changed 12 years ago by eco

Hello Roderik, don't forget to add: "This bug-report is for information/statistics only."

OK, Pasha talks that the snooopers may use OEMHLP. ACPI changes OEMHLP => something goes wrong?

the process is long, it's necessary print debug info from new oemhlp.

comment:5 Changed 12 years ago by ecsnl

What do you mean with : "This bug-report is for information/statistics only.".

Pasha can reproduce this situation by loading the attached resource.sys ? It happens on all test machines here in the Mensys test lab. So its not machine specific bug. Load ACPI.PSD, output of PCIBUS.SNP missing. Don't load ACPI.PSD and output of PCIBUS.SNP is included.

What was done is this version of RESOURCE.SYS (attached to this bug)looks for PREVIOUS.ACP.

Changed 12 years ago by ecsnl

Attachment: resource.sys added

comment:6 Changed 12 years ago by Steven Levine

Milestone: Release version 3.10Release version 3.11

comment:7 Changed 11 years ago by pasha

About what ticket?

comment:8 Changed 11 years ago by ecsnl

What do you mean ?

comment:9 Changed 11 years ago by pasha

With acpi not load -previous.dat problem With acpi load - previous.dat problem.

Where is problem in acpi?

comment:10 Changed 11 years ago by pasha

Owner: changed from pasha to acpi-admin

comment:11 Changed 11 years ago by Steven Levine

Milestone: Release version 3.15Release version 3.16

comment:12 Changed 11 years ago by Steven Levine

Owner: acpi-admin deleted

comment:13 Changed 11 years ago by ecsnl

Reporter: changed from Chuck McKinnis to ecsnl

comment:14 Changed 11 years ago by ecsnl

I don't know if it it important. All I notice is when I load ACPI.PSD (does not matter which machine). All output from PCIBUS.SNP is missing. Output like PCI "Device 06-04-00 Bridge: PCI to PCI" look in previous_correct.dat for example. PREVIOUS.DAT is result of loading ACPI.PSD.

Question is can this be harmfull for functioning of machine ? Device drivers need correct resource information.

What output of RMVIEW do you need ?

OK, Pasha talks that the snooopers may use OEMHLP. ACPI changes OEMHLP => something goes wrong? the process is long, it's necessary print debug info from new oemhlp.

How do I get this output ?

comment:15 Changed 8 years ago by David Azarewicz

Milestone: Release version 3.19Feedback pending

This ticket is really old and probably is not relevant to the current software. Is this still a problem?

comment:16 Changed 8 years ago by Lars Erdmann

David,

this problem was fixed with the most recent update to PCIBUS.SNP done by Veit Kannegieser. As far as I remember the problem was that there was wrong use of the OEMHLPs to read PCI config space.
This problem is definitely fixed and the latest PCIBUS.SNP (end of 2011) now properly shows all devices detected on PCI bus.

comment:17 Changed 8 years ago by David Azarewicz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.