Opened 11 years ago

Closed 9 years ago

#255 closed defect (unknown)

ASUS A8V DELUXE, troubles in SMP APIC

Reported by: eco Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.09
Keywords: Cc:

Description

e-co:

VIA chipset

Boots to SMP APIC - OK,

troubles:

  • sound is chokky, etc - troubles of uniaud
  • boot is slow!!

Attention, there were troubles with ASUS A8V already:

Change History (18)

comment:1 in reply to: ↑ description Changed 11 years ago by Yagiza

  • Summary changed from ASUS A8V, troubles in SMP APIC to ASUS A8V DELUXE, troubles in SMP APIC

Replying to eco:

e-co:

VIA chipset

Boots to SMP APIC - OK,

troubles:

  • sound is chokky, etc

When boot with /SMP parameter any sound goes into an infinite loop until the next one. The problem persists with both uniaud (regardless of version) and native sound driver.

  • boot is slow!!

When boot with /APIC parameter boot process is awfully slow: every driver (starting from the first BASEDEV=...) starts ~10 times slower than it normally does.

Attention, there were troubles with ASUS A8V already:

comment:2 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.10 to Release version 3.11

comment:3 Changed 11 years ago by eco

<YAGIZA> Результаты замеров с секундомером: <YAGIZA> (Мерялось время от появления логотипа eCS в углу до перехода в

графический режим)

<YAGIZA> PIC - 2 минуты 21 секунда <YAGIZA> APIC - 5 минут 35 секунд (при этом я ещё и заремил все USB) <YAGIZA> Да... Даже с отладочным ядром и ACPI разница весьма ощутима... <YAGIZA> Стремиться надо к PIC (т. е. без /APIC)

Try this:

irq с 3 по 7.. ассигновать для ISA

comment:4 Changed 11 years ago by eco

Shutdown doesn't work

========

<YAGIZA> Когда открал командную строку и написал в ней poweroff, комп немного пошелестел винтом и намертво повис (мышка не

ползает)

<YAGIZA> Вот лог: <YAGIZA> OemHlpXHandler: CMD_SHUTDOWN 0 <YAGIZA> OemHlpXHandler: CMD_SHUTDOWN 0 <YAGIZA> OemHlpXHandler: CMD_SHUTDOWN 1 <YAGIZA> OemHlpXHandler: CMD_SHUTDOWN 1 <YAGIZA> State to sleep:5 <YAGIZA> AcpiOsDerivePCIID([PCI0] ,[PWCR],) Bus:0 Dev:17 Fun:0 - Derive: Bus:0 Dev:17 Fun:0 <YAGIZA> AcpiOsDerivePCIID([PCI0] ,[ACLK],) Bus:0 Dev:17 Fun:6 - Derive: Bus:0 Dev:17 Fun:6 <YAGIZA> AcpiOsDerivePCIID([PCI0] ,[BSR0],) Bus:0 Dev:0 Fun:4 - Derive: Bus:0 Dev:0 Fun:4 <YAGIZA> hwsleep-440 [1851] EnterSleepState?: Entering sleep state [S5] <YAGIZA> AcpiOsStall? 10000000 us <YAGIZA> Гм! Батарея в моём бучке сдохла совсем...

comment:5 Changed 11 years ago by eco

Current state:

Нет. Всё как и раньше. Без звука и без /APIC. Я без звука работать не могу и поэтому сижу на UNI.

comment:6 Changed 11 years ago by eco

<CaPr?|c0rN> |e-co|7 , SMP я так и не заставил работать по-человечески.

<|e-co|7> но ты загружаешься с 2 CPU? т.е. на пульсе 2 проца?

<CaPr?|c0rN> |e-co|7 , да

<|e-co|7> у тебя была долгая загрухка. это я помню.

<|e-co|7> опять напомни,

<|e-co|7> сколько минут идет хагрузка?

<CaPr?|c0rN> |e-co|7 , но при этом половина программ виснет при запуске, включая OpenChat?,

<|e-co|7> аа...

<|e-co|7> ос какая?

<|e-co|7> ecs/rus 1.2.5? или 2.0?

<CaPr?|c0rN> |e-co|7 , 2.0rc4

<|e-co|7> так..

<|e-co|7> попроюуй ecs 2.0 rc5 установить?

<|e-co|7> у тебя есть iso?

<CaPr?|c0rN> |e-co|7 , если гружусь без /APIC - то как обычно. А если с /APIC, то либо вообще, не грузится либо грузится минут

20...

<|e-co|7> /smp /pic грузится и все ок?

<|e-co|7> просто /smp

<CaPr?|c0rN> |e-co|7 , я же писал: rc5 не ставится

<CaPr?|c0rN> |e-co|7 , грузится, но глючит

<CaPr?|c0rN> |e-co|7 , это про /PIC

<|e-co|7> у тебя HT или AMD X2 ?

<CaPr?|c0rN> |e-co|7 , AMD

<|e-co|7> AMD X2

<CaPr?|c0rN> |e-co|7 , угу

<|e-co|7> всякие /TMR пробовал?

<|e-co|7> /!NOD пробовал?

<CaPr?|c0rN> |e-co|7 , не помню. Пробовал то, что Паша советовал...

<|e-co|7> http://ru.ecomstation.ru/projects/acpitools/?action=hardware

comment:7 Changed 11 years ago by eco

Pasha: ну видимо нижнюю память хто-то скушал

fat32, ntfs отключить

ядро он наверное нужное поставил

earlymeminit

comment:8 Changed 11 years ago by eco

Capricorn:

I tried ACPI 3.11 - the same problems. I disabled NTFS, FAT32, tried EARLYMEMINIT - the system still unusable.

Pasha:

Please try the latest ACPI

e-co:

Please check shared memory using SHMEMMON utility:

  • Virtual memory technique

http://os2voice.org/VNL/past_issues/VNL1007H/feature_3.html

  • Virtual Memory Problems under OS/2

http://www.os2voice.org/VNL/past_issues/VNL0708H/feature_3.html

Pasha:

please come to irc-channel, let's test the latest ACPI build together.

comment:9 Changed 11 years ago by eco

Capricorn:

1) I added DLLBASING=OFF to config.sys

2) Updated SMP kernel (right doscall dll)

3) replaced OS2LDR to the latest one

Now I can start openchat.

Other programs still don't startup

comment:10 Changed 11 years ago by eco

e-co:

Please upgrade BIOS. This helped for ~ 10 users in the past.

comment:11 Changed 11 years ago by eco

e-co:

/SMP /APIC

Please try different versions of ACPI 3.05, 3.09, 3.11, 3.13, 3.14

comment:12 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:13 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:14 Changed 11 years ago by eco

e-co:

1-5 times per week (november - february) Capricon comes to #ecolabs channel and we continue tests.

So.. this ticket is alive

comment:15 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI315PRE.ZIP

comment:17 Changed 10 years ago by pasha

  • Owner pasha deleted

comment:18 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.