Opened 11 years ago

Closed 11 years ago

#253 closed defect (fixed)

SMP not working with Athlon 64 X2 4600+ and ACPI 3.09

Reported by: guest Owned by: pasha
Priority: blocker Milestone: Release version 3.10
Component: ACPI PSD Version: 3.09
Keywords: Cc:

Description

Hi all, I have just upgraded my CPU and memory. My new CPU is an Athlon 64 X2 4600+ (socket AM2). My motherboard is an ASRock AM2NF6G-VSTA. I had to upgrade the BIOS to support the new processor, so I upgraded to the latest available version: 2.30. I have eCS 1.2MR installed and I regularly apply updates from eCSMT. Previously I had a Sempron 3200+, so I had the UNI kernel. I installed the SMP kernel and related DLLs, then tried to enable SMP in ACPI.

Here are my results:

1) PC works as before in 1 CPU mode (PSD=ACPI.PSD /CD), just faster.

2) If I enable SMP but do NOT enable APIC (PSD=ACPI.PSD /SMP /CD) I can boot to command line without problems. When I try to start PM, I get a trap D in the kernel before reaching the desktop. I tried several combinations of switches *without* /APIC with the same results.

3) If I enable SMP _and_ enable APIC (PSD=ACPI.PSD /SMP /APIC /!NOD /ALS) the computer hangs during the boot process. I tried several combinations of switches *with* /APIC with the same results. Note that on first boot with /APIC I could not boot because eCS said it was unable to operate my disks. I have SCSI disks, and I boot off an SCSI disk. Then I read how to remap high IRQs to the original low IRQs, and after doing it eCS was able to boot, but then it hung. I noticed that HDA audio gets an high IRQ too, so I tried to remap it too, but this time it didn't work. Maybe it is because I try to remap to IRQ 11 which is already used by SCSI... but when in PIC mode they share that IRQ without problems. That's because you find three remapped IRQs in the acpi.cfg file.

LOGS:


You find attached logs that I collected for situation number (2). I could not collect logs from AcpiManager? because that would have started PM, which in turn would have caused the trap.

Image 148 refers to the kernel trap that occurs few seconds after when I start PM.

Image 149 refers to the hang that I get in situation number (3).

The fans are always quite loud when in SMP mode (with or without /APIC).

Hope this helps! I really want to use my new dual core processor! ;-)

Bye Cris (criguada at gmail dot com)

Attachments (9)

acpi-log-Model-of-your-PC.ziq (80.2 KB) - added by guest 11 years ago.
img148.JPG (183.9 KB) - added by guest 11 years ago.
kernel trap
img149.JPG (153.4 KB) - added by guest 11 years ago.
Hang on boot (situation 3)
s6300151.jpg (168.1 KB) - added by guest 11 years ago.
latest hang, with /TMR
acpica.log (11.8 KB) - added by guest 11 years ago.
acpica.log generated with ACPI.PSD /CD
other0007.JPG (154.4 KB) - added by guest 11 years ago.
Photo of screen when computer hanging on boot
acpica.2.log (8.2 KB) - added by criguada 11 years ago.
acpica$ log of the succesful SMP boot
acpica_als.log (8.2 KB) - added by criguada 11 years ago.
acpica$ log of the succesful SMP boot with /ALS
other0008.JPG (179.3 KB) - added by criguada 11 years ago.
Trap screen when starting PMSHELL in /SMP /APIC mode

Download all attachments as: .zip

Change History (35)

Changed 11 years ago by guest

Changed 11 years ago by guest

kernel trap

Changed 11 years ago by guest

Hang on boot (situation 3)

comment:1 follow-up: Changed 11 years ago by pasha

Your MB can't work in /PIC mode. Use /APIC

comment:2 in reply to: ↑ 1 Changed 11 years ago by guest

Replying to pasha:

Your MB can't work in /PIC mode. Use /APIC

Hi Pasha, as you can see I can't boot with /APIC: the PC always hangs during boot. Please see img149.jpg. This is the photo of the hang, taken with debug ACPI.PSD.

comment:3 Changed 11 years ago by pasha

Try add /TMR

comment:4 follow-up: Changed 11 years ago by eco

e-co:

btw,

readme and the list tell how to run AMD X2: http://ecomstation.ru/projects/acpitools/?action=hardware

You have SCSI, so read this document: http://ecomstation.ru/projects/acpitools/?action=acpi-scsi

comment:5 in reply to: ↑ 4 Changed 11 years ago by guest

I have already read all the documents available. That's how I discovered how to remap IRQs and make my SCSI adapter work. I already tried the ACPI switches suggested in the docs, without success. BTW, in the first doc you will find TWO different (and apparently conflicting) ways suggested to run AMD X2 CPUs.

I tried with /TMR as per your latest suggestion, but I still had the hang on boot. I also tried to disable most of the drivers, even USB drivers, but I still had the hang. I am attaching another photo of the hung computer, with debug ACPI.PSD installed, taken after my last trial. The output from ACPI.PSD is partially overlaying what was on screen before, so I don't know if you can understand the output.

Changed 11 years ago by guest

latest hang, with /TMR

comment:6 Changed 11 years ago by pasha

You need add /APIC, your MB can't work in /PIC mode. In APIC mode you can't see at screen "HDA Nvidia 0xXXXXXX IRQ11", IRQ11 don't possible in APIC mode

comment:7 Changed 11 years ago by guest

Pasha, I *do* have /APIC. You see IRQ11 becuase I have this in my acpi.cfg:

REMAP 17 TO 10 REMAP 18 TO 11 REMAP 23 TO 11

This is necessary to have my SCSI controller working, and I did it because I read it in the ACPI-SCSI docs (they say to remap the SCSI controller IRQ back as they were in PIC mode). This made my SCSI controller work, otherwise eCS would not boot saying it can't operate my disks (I boot off an SCSI disk).

The last REMAP is my HDA-audio onboard controller; I did this in a trial to have the system not hang: since it was on IRQ 11 in PIC mode, I tried to remap it to 11 even when in APIC mode. I have seen this sometimes succeeds and sometimes not... I have not tracked to cause. Maybe it works without !NOD and it does not work if I specify !NOD. I simply don't know because it didn't seem important.

If I have to remove the *LAST* REMAP, I'll do it, no problem... at this point it is clear that the hang is not due to the HDA controller being on IRQ 23. BUT I can't leave out the two initial REMAPs because otherwise my SCSI controller will not work. Or should I remap it to other IRQs? I don't know if I have other low IRQ free to use.

Please let me know what should I do

Thank you Bye Cris

comment:8 Changed 11 years ago by guest

Pasha, the wiki joined the lines together, but I obviously have the three REMAPs on different lines.

comment:9 follow-up: Changed 11 years ago by pasha

This remap is wrong. You can't remap diff high IRQ to one low IRQ. Low IRQ must be diff too. For you MB you can try next:

/SMP /APIC /!NOD

comment:10 in reply to: ↑ 9 Changed 11 years ago by guest

Pasha, I have tried again using the parameters you suggested (/SMP /APIC /!NOD). I have tried several times, without success. I always get the hang.

I have several questions for you:

1) You told me the remap is wrong. So I removed the last remap from ACPI.CFG. The problem is that I cannot get HDA to go to high IRQ anymore. It stays on IRQ 11 even if I removed the REMAP. I tried everything I could think of (enabling full hardware detection, changing various parameters in BIOS) but it always comes up on IRQ 11. Why? It was using IRQ 23 at some point in time. How can I fix this?

2)One of the BIOS options I tried to change is "Enable ACPI HPET table". What's this? Is it necessary?

3) I read in the docs that most VDM drivers are "bad" for APIC mode. Should I remove *EVERY* VDM driver from the config.sys? That means losing DOS and WINOS2 support. I can bear it, but is it necessary? Should I perhaps run in PROTECTONLY mode?

4)On one trial, I left for dinner while the computer was booting. When I got back, there were two more lines after the point where it usually hangs. I have tried again, and it is reproducible: if I leave it hanging for enough time (about 4-5 minutes I think) it spits one error, then - after another minute - another error. This errors are SYS01200 and SYS02066. First one means "The system cannot create the DOS environment.", second one means "DOS cannot be started.". Can this be useful to understand the reason of the hang? Why should eCS try to initialize the DOS environment during boot?

Thank you! Bye Cris

comment:11 follow-up: Changed 11 years ago by pasha

1) I need log

2) HPET is timer, OS/2 don't support it at this time

3) need only ProtectOnly?=yes

4) Need log

comment:12 in reply to: ↑ 11 Changed 11 years ago by guest

Replying to pasha:

1) I need log

Please tell me how do I have to do it: since the boot hangs I cannot collect logs when using this parameters.

2) HPET is timer, OS/2 don't support it at this time

OK, I will disable it then.

3) need only ProtectOnly?=yes

Great, I'll try with PROTECTONLY=YES and will let you know.

4) Need log

Same as point (1): how am I supposed to collect logs if computer hangs?

Thank you! Bye Cris

comment:13 Changed 11 years ago by guest

Pasha talks about fresh acpi.log when system is loaded without /SMP switch.

comment:14 Changed 11 years ago by pasha

If log is't possible - give photo of screen

comment:15 Changed 11 years ago by guest

I'll do both: fresh acpi.log as suggested by guest, and photo of screen when computer is hung (with debug acpi.psd), ok? Please allow three more days since I'll be away for work.

Bye Cris

comment:16 Changed 11 years ago by pasha

What is the option for acpi.psd ?

comment:17 Changed 11 years ago by guest

Hi! I am attaching acpica.log generated when running NOT in SMP mode (ACPI options used: /CD). I am attaching photo of screen when computer is hanging on boot running in SMP APIC mode with PROTECTONLY=YES (ACPI options used: /SMP /APIC /TMR /!NOD /ALS - note that I have also tried almost all variations of parameters with /SMP /APIC, and I have always had the hang).

Thank you Bye Cris

Changed 11 years ago by guest

acpica.log generated with ACPI.PSD /CD

Changed 11 years ago by guest

Photo of screen when computer hanging on boot

comment:18 Changed 11 years ago by criguada

Hi Pasha, do you have any news for this ticket? Maybe you need more information?

Bye Cris

comment:19 Changed 11 years ago by pasha

Need use /SMP /APIC /TMR /!NOD, and all comment in acpi.cfg

comment:20 Changed 11 years ago by criguada

Pasha, I have some good news. I tried disabling everything DOS-related in config.sys, and also disabling most OS/2 device drivers... everything I could, really. Then I edited the ACPI.PSD line to add the options you suggested (/SMP /APIC /TMR /!NOD), and finally I edit the PROTECTONLY line to have YES instead of the usual NO. This way, I can boot completely to a full-screen command line (i.e. no PM), with no hang (at last!!!). From this command line, I collected the ACPICA$ log and I am attaching it here.

Now I have to find which is/are the driver(s) that make the boot hang, but first I have to solve (with your help hopefully) a couple problems:

1) Of the two CPUs that eCS now sees, one is apparently always at 100% load

2) If I start PM (with the PMSHELL command), I get a trap as soon as eCS tries to switch to the graphical mode (screenshot attached)

One note: I could not comment out everything in ACPI.CFG because if I do it my SCSI controller doesn't work (and I boot off a SCSI disk). So I still have these two lines in my ACPI.CFG:

REMAP 17 TO 10 REMAP 18 TO 11

Could this be a problem? Should I avoid it? If so, how?

Another note: I tried also adding /ALS to see if it solves the trap starting PMSHELL. It does not solve it. However, I collected the ACPICA$ log in this mode also, so that you can see if it makes a difference. It is attached as acpica_als.log.

Thank you Bye Cris

Changed 11 years ago by criguada

acpica$ log of the succesful SMP boot

Changed 11 years ago by criguada

acpica$ log of the succesful SMP boot with /ALS

Changed 11 years ago by criguada

Trap screen when starting PMSHELL in /SMP /APIC mode

comment:21 Changed 11 years ago by criguada

Hi Pasha, do you need any more info from me?

Cris

comment:22 Changed 11 years ago by eco

Pasha reminds:

disable (remove) REMAP lines

try boot with /SMP /!NOD /APIC attach logs / photos

comment:23 Changed 11 years ago by criguada

eco, did you bother to read what I wrote?

1) I _CANNOT_ boot without the REMAPs 2) I already sent logs and photos

What should I do now?

comment:24 Changed 11 years ago by pasha

  1. del \os2\boot\acpi.cfg
  1. psd=acpi.psd /SMP /APIC /!NOD /TMR

if trap - show fhoto

comment:25 Changed 11 years ago by criguada

OK Pasha, it is working now!!! SCSI card is working too, and without REMAPs!!! At first I didn't understand why I wasn't able to make it work on my last trial, then I saw it: I was writing /ACPI instead of /APIC... so I guess I was still running in PIC mode instead of APIC (you can see I was mistyping if you look in the LOGs I sent). It seems that APIC mode on nVidia doesn't bump my SCSI card on high IRQs (yes, I know, it is written in the docs). Now it is working fine with the trimmed-down CONFIG.SYS. I have to discover what makes it hang on boot when I use the full-blown CONFIG.SYS. Thank you!

comment:26 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

OK, fixed

Note: See TracTickets for help on using tickets.