Opened 5 years ago

Closed 10 months ago

#21 closed defect (wontfix)

XWLAN does not reconnect after connection drops

Reported by: andib Owned by:
Priority: Feedback Pending Milestone:
Component: engine Version: 3.12
Keywords: Cc:

Description

Some people complained about not reconnecting after connection drops but keep in 'searching...' state. This ticket is to collect the infos.

Paperino	Andi_aw: first, it does not start dhclient itself...
...
Paperino	Andi_aw: where is your dhclient exe located? here in d:/usr/sbin/dhclient.exe
...
Paperino	Andi_aw: 2nd issue: sometimes here connection drops for some unknown reason; then xwlan enters 'searching...' state and it never reconnects to wlan.
...
Paperino	Andi_aw: closing xwlan and restarting it correctly connects to interface.
Paperino	Andi_aw: closing xwlan and restarting it correctly connects to wlan.
...
Andi_aw	connection drop is a dhclient or wpa problem?
Paperino	Andi_aw: ah dhclient does not close...
Andi_aw	dhclient is killed whenever switching between profiles or activate/deactivate (better solution would be signals to dhclient)
Paperino	Andi_aw: dhclient is not killed when searching for networks
...
Andi_aw	OTOH when connection only drops for a short time, the 'old' IP should be valid anyway, isn't it?
Paperino	Andi_aw: yes, xwlan window changes bitmap and instead of signal level shows brown bars. The tooltip says 'searching for networks' and never ends...
...
altsan	I sometimes see that on certain networks.
altsan	Especially when connecting to my smartphone WiFi tether
...
Paperino	Andi_aw: XWLAN closes wpa supp when network disconnects... and wpa window is not visible while searching.

Change History (5)

comment:1 Changed 5 years ago by andib

Now I can reproduce a scenario where xwlan loses connection and does not reconnect. Switching Access Point off for a short time and on again. This leads to xwlan start searching while dhclient and wpa_supplicant are still running (without killing them as it would be when connection drops for a long time).

In this state it is sufficient to send reassociate to the wpa_supplicant. In fact I've implemented this now and it works for me.

But I fear what Yuri and Alex describes above are different cases.

Feedback required. One thing to try in case connection dropped is 'Properties - WPA Supplicant - Reconnect'.

Last edited 5 years ago by andib (previous) (diff)

comment:2 Changed 5 years ago by ydario

do you have a download URL?

comment:3 Changed 5 years ago by andib

http://members.aon.at/buchinger/Download/xwlan312beta3.zip

But if your problem is not wpa_supplicant (I do not even know if you use it) then it will make no difference.

And if you're problem is wpa_supplicant and this version does still not reconnect please try properties menu entry 'Properties - WPA Supplicant - Reconnect' and see if this works. 'Properties - WPA Supplicant - Visible'. Debuglevel 'normal' is enough when you want to follow wpa_supplicants messages.

Last edited 5 years ago by andib (previous) (diff)

comment:4 Changed 4 years ago by andib

  • Priority changed from major to Feedback Pending

comment:5 Changed 10 months ago by andib

  • Resolution set to wontfix
  • Status changed from new to closed

No feedback since years.

Note: See TracTickets for help on using tickets.