Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#99 closed enhancement (fixed)

ASUS EeePC 701 + Intel HDA6 Sound + ALC662

Reported by: guest Owned by:
Priority: normal Milestone: HDA
Component: Building Version: 1.1.4
Severity: normal Keywords:
Cc:

Description

Hi, my name is Sigurd Fastenrath and among others I try to bring OS/2 - eCS on the ASUS EEE-PC. Progress is already made, Video settings and installaion are available. I tried to get sound working.

It is an Intel chipset with the ALC662 set. I use ecomstation 2.0RC4.

My result so far:

1.) latest UNIAUD 1.1.4 RC 4 causes a boot trap (cant initialise hardware) - pleasesee the attached debuginfo.zip

2.) Several trial and errors leads to only one driver, that passes the boot process. It shows the OS/2 audio and the Intel HDA marks in Hardwaremanager (using IRQ 5, shared with graphic controller and EHCI USB). But there is no sound. It is release 1.1.3 from 12/2005. THe included IBM Games (e.g. mahjong) says during start: No device availiable" . Therefore I included debuginfo == 1 == .zip, taken from this configuration.

Would be great if someone could help, meanwhile other people are already working on the WLAN and LAN issue,using GENMAC. So there is a realistic chance to turn the EEE in a real usable miniPC.

If more hardwareinformation or something else is needed, please contact me sigurd.fastenrathANTISPAM@… (delete ANTISPAM)

TIA

Sigurd

Attachments (1)

debuginfo1.zip (5.0 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

comment:1 Changed 12 years ago by guest

  • Milestone set to 1.1.4GA
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement
  • Version set to 1.1.4

Hi, solved this problem on my own. The trick is :

  1. install the uniaud 1.14 RC 4
  1. before reboot - copy uniaud32.sys, version 1.1.3, file date: 9.7.2006 into c:\mmos2\ and replace the newer one.
  1. reboot.

Now you sholud have sound on the EEE PC, with a mixed uniaud32 (1.1.3) and uniaud16 (1.14RC4).

It works at least for me. Thanks for the attention.

Sigurd

comment:2 Changed 12 years ago by guest

Reverting to an old version is hardly a fix. Try 1.1.4RC5; if that works, great, otherwise, you may want to reopen this ticket.

comment:3 Changed 12 years ago by yoda

  • Milestone changed from 1.1.4GA to milestone4
Note: See TracTickets for help on using tickets.