Opened 14 years ago

Closed 3 months ago

#9 closed enhancement (wontfix)

won't play midi songs

Reported by: jryan@… Owned by:
Priority: lowest Milestone: MMPM/2 Compatibility
Component: UNIAUD16 Version: 1.1.4
Severity: normal Keywords: MIDI
Cc:

Description

plays wav sounds ok plays movie sounds ok will not play midi songs will not play songs I generate from Nota Musica .NMF files running eComstation on IBM thinkpad A21M cpu 750

Change History (4)

comment:1 Changed 12 years ago by Yoda

Keywords: MIDI added
Milestone: milestone2
Priority: normallowest
Type: defectenhancement
Version: 1.1.4

Uniaud doesn't currently support MIDI.

We will look at this in future.

comment:2 Changed 12 years ago by Brendan Oakley

Component: UNIAUD-APIUNIAUD16
Owner: vladest deleted

comment:3 Changed 3 months ago by martini

Hi

Just to include something more to this topic and not relates to UniAud?. There is a way to play MIDI files in OS/2 by software.

You can use Timidity++ port to OS/2. http://www.altsan.org/programming/ports/ It has an command line tool and GUI to play MIDI files.

The issue is that this utility is not integrated to MMOS2. This means that if you have an application that tries to plays MIDI files with MMOS/2 (Like an OS/2 game) it won't be able to play it.

So, what we are missing is somekind of MMOS2 CODEC that bridges MIDI play sound requests to Timidity++.

Regards

comment:4 Changed 3 months ago by martini

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.