Opened 9 years ago

Closed 9 years ago

#185 closed defect (duplicate)

uniaud193_21 report

Reported by: losepete Owned by:
Priority: normal Milestone:
Component: Building Version: 1.9.14
Severity: normal Keywords:
Cc:

Description

Hardware: nVidia HDA MCP61 audio + Analog Devices AD1988 mixer

Installed the uniaud*.sys drivers and rebooted

No looping or repeating Startup sound - but system sounds now have an unwanted "end of playback noise".

The noise may be part of the WAV file. As most previous versions of uniaud did not have the noise at the end of system sound playback I suspect uniaud was previously coded to not "play" the noise.

I do seem to recall there was some discussion about this in the uniaud mailing list awhile back but cannot find the thread at the moment.

Application audio playback - limited testing

No sound in WindowsXP running in VirtualPC/2

Klondike Solitaire: Deals and plays slowly - not sure if this is uniaud related but with the uniaud drivers usually in use here this game is much quicker when dealing and playing.

Possibly of interest: Reading the Control ID list obtained by this command

unimix -list > ad1988.txt

Shows Control IDs to be incorrect:-

Command line mixer for UNIAUD. Version 0.05 Copyright 2004,2005 by Netlabs.org Written by Vlad Stelmahosky aka Vladest Detected UNIAUD version 2.10 Detected 1 audio adapter(s) Control ID: 1 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Front Playback Volume] Index: 0 Element type: integer type Count of values: 2 Value:

Bounds: min: 0, max: 39, step: 0

value 1: 0 value 2: 0

Control ID: 2 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Front Playback Switch] Index: 0 Element type: boolean type Count of values: 2 Value:

Bounds: min: 0, max: 1, step: 0

value 1: 1 value 2: 1

Control ID: 3 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Headphone Playback Switch] Index: 0 Element type: boolean type Count of values: 2 Value:

Bounds: min: 0, max: 1, step: 0

value 1: 1 value 2: 1

Control ID: 4 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Mic Playback Volume] Index: 0 Element type: integer type Count of values: 2 Value:

Bounds: min: 0, max: 31, step: 0

value 1: 0 value 2: 0

The [Headphone Playback Volume] should be Control ID 3 but is in fact missing from the Control ID list. This has the knock on effect of all Control IDs from 3 inclusive being incorrect.

uniaud 1.9.2 is the *last* build of uniaud that got that right:-

Command line mixer for UNIAUD. Version 0.05 Copyright 2004,2005 by Netlabs.org Written by Vlad Stelmahosky aka Vladest Detected UNIAUD version 1.92 Detected 1 audio adapter(s) Control ID: 1 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Front Playback Volume] Index: 0 Element type: integer type Count of values: 2 Value:

Bounds: min: 0, max: 39, step: 0

value 1: 0 value 2: 0

Control ID: 2 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Front Playback Switch] Index: 0 Element type: boolean type Count of values: 2 Value:

Bounds: min: 0, max: 1, step: 0

value 1: 0 value 2: 0

Control ID: 3 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Headphone Playback Volume] Index: 0 Element type: integer type Count of values: 2 Value:

Bounds: min: 0, max: 39, step: 0

value 1: 0 value 2: 0

Control ID: 4 Interface: virtual mixer device Device(client): 0, subdevice (substream) 0 Name: [Headphone Playback Switch] Index: 0 Element type: boolean type Count of values: 2 Value:

Bounds: min: 0, max: 1, step: 0

value 1: 0 value 2: 0

I have attached the required log as 20100717-uniaud-2.1.zip

Regards

Pete

Attachments (1)

20100717-uniaud-2.1.zip (13.1 KB) - added by losepete 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by losepete

comment:1 Changed 9 years ago by dazarewicz

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #183

Note: See TracTickets for help on using tickets.