Opened 11 years ago

Closed 9 years ago

#161 closed defect (fixed)

sound loops with RC6 / 1.9.11

Reported by: rudi Owned by: psmedley
Priority: normal Milestone:
Component: Building Version: 1.9.11
Severity: major Keywords:
Cc:

Description

When running EmperoarTV 2.x (DVB), the sound works for a while but occasionally enters a loop repeating the last buffer. In rare situations normal playback continues after a few seconds. Mostly it doesn't. It also seems that the DART interface sometimes refuses to accept data at the expected rate, which leads to slow motion video (AV sync "thinks" that video is significantly ahead of audio and has to be slowed down).

The behavior might be triggered by / related to DART buffer underruns or quick start/pause/stop state changes.

I see this here on nVidia AC'97 / ALC650D / no ACPI involved. RC4 does not behave that way.

Attachments (1)

looping.zip (4.9 KB) - added by rudi 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by rudi

comment:1 Changed 10 years ago by psmedley

  • Owner set to psmedley
  • Status changed from new to assigned
  • Version changed from 1.1.4RC6 to 1.9.11

comment:2 Changed 10 years ago by psmedley

Does this still occur with 1.9.14?

comment:3 Changed 10 years ago by fbakan

Sound loops still occur with 1.9.14.

Situation here (T42 and T23): Sometimes I get soundloops after starting these laptops when playing the second 'system-sound'. Only solution (I know) is to reboot. Sometimes everything is ok. I also sometimes get soundloops with emporaer - In this case it's ok to restart emporaer to cure the problem.

comment:4 Changed 10 years ago by rudi

I just tried 1.9.20. The problem is the same. As soon as I disconnect the antenna from my DVB-T receiver (i.e. DART goes into a buffer underrun condition followed by a PAUSE command from my application) the sound starts to loop.

However, I'm quite positive that it's caused by UNIAUD16 as downgrading this driver to 114RC4 or 114RC2 fixes it.

comment:5 Changed 10 years ago by rudi

Now I did some more tests. Obviously there was some confusion about the driver versioning. The first UNIAUD16s that expose the problem are these two versions (both 72814 bytes long).

Vendor:          Netlabs
Revision:        1.01
Date/Time:       31 Oct 2008 15:35:49
Build Machine:   mail.smedl
FixPak Version:  R396
File Version:    1.1.4
Description:     Universal Audio MMPM/2 Driver for eComStation

and

Vendor:          Netlabs
Revision:        1.01
Date/Time:       22 Nov 2008 14:44:24   
Build Machine:   OBIWAN    
FixPak Version:  RC7
File Version:    1.1.4
Description:     Universal Audio MMPM/2 Driver for eComStation

The older RC6 version (72926 bytes) behaves O.K.

Vendor:          Netlabs
Revision:        1.01
Date/Time:       2 Apr 2008 20:41:20
Build Machine:   OBIWAN
FixPak Version:  RC6
File Version:    1.1.4
Description:     Universal Audio MMPM/2 Driver for eComStation

So something bad must have happened to UNIAUD16 between april and october 2008.

comment:6 Changed 10 years ago by psmedley

Thanks Rudi - I'll take a look at what changed between RC6 & R396.

If we can isolate which change broke things, we might be able to revert it.

comment:7 Changed 10 years ago by rudi

It may be possible, that the change fixed something for HDA hardware but introduced a regression for AC97.

comment:8 Changed 10 years ago by Lewisr

I can confirm your findings, Rudi. Following up on our discussion on the ETV forum, I rolled uniaud16.sys back form the one included with 1.9.22 to the original from 1.1.4RC6, and the persistent 52-minute hang with looping sound is resolved.

This is using Intel HDA:

Bus 0 (PCI Express), Device Number 27, Device Function 0 Vendor 8086h Intel Corporation Device 27D8h 82801G (ICH7 Family) High Definition Audio

I have multiple UniInfo? passes available for this hardware. If it is helpful to run one under 1.9.22, please advise, and I shall attach it.

comment:9 Changed 9 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from assigned to closed

Please test with latest driver, reopen ticket if problem still exists.

Note: See TracTickets for help on using tickets.