Opened 12 years ago

Closed 7 years ago

#131 closed defect (too-old)

ACPI toolkit information

Reported by: Brendan Oakley Owned by:
Priority: highest Milestone: Stabilization
Component: Building Version: 1.1.4RC6
Severity: critical Keywords:
Cc:

Description (last modified by Brendan Oakley)

The version of the ACPI toolkit http://en.ecomstation.ru/projects/developer/?action=acpi used in a Uniaud build needs to be in the Uniaud32.sys bldlevel and maybe driver load output. Since there are multiple versions of the toolkit library there is no way to be sure which was used otherwise.

I was told shortly after the 1.1.4RC6 release that there would soon be a new toolkit that would fix something in Uniaud. But never received any more information than that.

For 1.1.4RC7 ideally I'd like to get word from the ACPI project about this rumored fix and whether we are still waiting or if 20080425 on ecomstation.ru is the one we need.

Change History (6)

comment:1 Changed 12 years ago by Brendan Oakley

Priority: normalhighest

comment:2 Changed 12 years ago by mckinnis

Not quite sure what you mean. ACPI.PSD does produce normal output in response to a bldlevel query.

comment:3 Changed 12 years ago by Brendan Oakley

Description: modified (diff)

Thanks for pointing out my lack of clarity. The ACPI toolkit is used for building the Uniaud32.sys driver so it works with the ACPI driver. To build the same Uniaud32 driver, you need to know which version of the toolkit was used to build it, so that is why I want the uniaud32.sys bldlevel to expose it.

comment:4 Changed 12 years ago by Brendan Oakley

I looked back in my notes/email what happened here, and ACPI did in fact promise to release an updated ACPI Toolkit immediately after after 1.1.4RC6 was released. This would have to be the 20080425 version. We were going to do another Uniaud RC after that, because, as it turned out, the one used in RC6 was not the right one. I wasn't told when the new toolkit was released, and then I forgot exactly what it was we were waiting for, and that RC6 had this deficiency. This might explain some IRQ trouble folks are having, as the new toolkit should allow Uniaud to assign high IRQ's.

comment:5 Changed 7 years ago by Silvan Scherrer

i guess this ticket is obsolete

comment:6 Changed 7 years ago by David Azarewicz

Resolution: too-old
Status: newclosed

This ticket is obsolete and no longer relevant.

Note: See TracTickets for help on using tickets.