Opened 12 years ago

Closed 11 years ago

#128 closed defect (unknown)

114RC6 is silent with NForce AC'97 (10DE:0059)

Reported by: Tom Brown Owned by:
Priority: normal Milestone: ALSA Hardware Compatibility
Component: UNIAUD32 Version: 1.1.4RC6
Severity: normal Keywords:
Cc: gyoung

Description

I have just installed eCS 2.0 RC5 on a Tyan S2895-A2NRF Thunder K8WE system with 2 x AMD Opteron 248 (2.2 GHz) cpus. RAM = 2 GiB. I finally got SMP working with ACPI 3.10. CONFIG.SYS contains: ACPI.PSD /SMP /APIC CD /TMR /!NOD I have System sounds disabled in the sound notebook. Attaching the output of Uniinfo run.

Any ideas?

Thanks!

Attachments (1)

debuginfo.zip (12.5 KB) - added by Tom Brown 12 years ago.
Output of Uniinfo.cmd

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by Tom Brown

Attachment: debuginfo.zip added

Output of Uniinfo.cmd

comment:1 Changed 12 years ago by gyoung

Cc: gyoung added

Verify that it got installed check config.sys. It failed to install at all here with RC5 and the multimedia installer fails also.

comment:2 Changed 12 years ago by Tom Brown

Uniaud16.sys and Uniaud32.sys are both in config.sys. Boot shows:

Universal Audio Driver for OS/2 and eComStation v1.1.4RC6 DEBUG Based on Alsa Copyright 2005-2008 Netlabs http://www.netlabs.org Copyright 2000-2008 The Alsa Project

NVidia CK804 at 0xb0002000, irq 11 Detected Mixer: Analog Devices AD1981B

OS/2 Universal Audio MMPM/2 Driver V1.1.4-RC6 DEBUG Copyright 2000-2002 InnoTek? Systemberatung GmbH Copyright 2002 IBM Corporation Maintained by Netlabs http://www.netlabs.org

RMVIEW shows that the CK804 is sharing IRQ 11:

IRQ Level = 11 PCI Pin = B Flg = SHARED EHCI Compliant USB Host Controller IRQ Level = 11 PCI Pin = NONE Flg = SHARED NVidia CK804 IRQ Level = 11 PCI Pin = A Flg = SHARED IDE_1 xATA Controller

Could this be causing a problem? Is "PCI Pin = NONE" a problem? If so, how do I get around it?

Thanks!

comment:3 Changed 12 years ago by Brendan Oakley

Component: BuildingUNIAUD32
Milestone: 1.1.4GA
Priority: highnormal
Severity: blockernormal
Summary: No sound from 114RC6 under eCS 2.0 RC5 SMP114RC6 is silent with NForce AC'97 (10DE:0059)

Thank you for reporting, and for the thorough description. I believe this might be the same issue as Ticket #108. If so, we need to fix it for 1.1.4GA. To verify, please replace just Uniaud32.sys with the one from 1.1.4RC4. You can get it from: ftp://ftp.netlabs.org/pub/uniaud/uniaud114RC4.zip

If that works, please email me privately, and with your permission I'll send you some test builds when I get some time. My address is this same username at G mail.

Can you explain what you mean that the System sounds are disabled. I'm confused because it sounds like if you enable them it will work, which doesn't seem right because you opened a ticket.

I do not think the shared IRQ is a problem.

comment:4 in reply to:  3 Changed 12 years ago by Brendan Oakley

Replying to gentux2:

Can you explain what you mean that the System sounds are disabled.

Nevermind, I get that now. Just a statement of fact.

comment:5 Changed 12 years ago by Brendan Oakley

Milestone: 1.1.4GAALSA Hardware Compatibility

comment:6 Changed 11 years ago by Paul Smedley

Resolution: unknown
Status: newclosed

Please try with a modern version of Uniaud from http://svn.netlabs.org/uniaud and reopen the ticket if the problem persists

Note: See TracTickets for help on using tickets.