Opened 11 years ago

Closed 10 years ago

#122 closed defect (unknown)

UNIAUD32 Problems with ICH7 + ALC662 - 1.1.4RCx and 1.9.x

Reported by: guest Owned by:
Priority: normal Milestone: HDA
Component: UNIAUD32 Version: 1.9.4
Severity: major Keywords: 1.1.4RC6 and 1.9.4
Cc:

Description

After I installed eCS RC4 to this new machine (Core2 Quad on a Gigabyte GA-G31M-S2L motherboard... of course, running on SMP mode) I was surprised by the fact the boot trapped during UNIAUD32 (1.1.4 RC4) loading. Well, I tried 1.1.4RC5 r 1.1.4RC6 and they both trapped in the same way. Then I reverted to 1.1.4RC3 and it trapped the same way. Only with UNIAUD 1.1.4 RC2 I had modest success. The results improved a lot when I used UNIAUD16 from 1.1.4RC6 + UNIAUD32 from 1.1.4RC2. The only complains are about random hangs during boot (sometimes the boot simply stops during UNIAUD drivers load, but this is uncommon), random (rare) hangs on the system. Also, the sound is not continuous. Sometimes it is somewhat interrupted or has its volume(?) changed during the audio play. The worst part is the fact that the driver probably is not correctly cleaning the house (buffers?) because it is *very* common that something keeps some WPS thread "hanged", causing problems during shutdown (the xShutdown progress window reports an exception had occurred and keeps waiting forever... I am obligated to kill CAD handler and reset using C-A-D).

I had tried Paul's UNIAUD 1.9.2, 1.9.3 and 1.9.4. As far as I remember, 1.9.2 keeps repeating sounds (buffer problem... instead of a "tadam!", the result is a "tadtadtadtadtad...(forever)". 1.9.3 and 1.9.4 just plays no sound at all.

I had disabled UNIAUD so I can work without the related problems, but that also means no sound, of course. :P

Attachments (2)

debuginfo_RC2_194.zip (7.6 KB) - added by guest 11 years ago.
Debug info running about "somewhat working" UNIAUD16 1.1.4RC6 + UNIAUD32 1.1.4RC2
debuginfo_RC2_RC6.zip (6.8 KB) - added by guest 11 years ago.
Debug info running about "somewhat working" UNIAUD16 1.1.4RC6 + UNIAUD32 1.1.4RC2

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by guest

Debug info running about "somewhat working" UNIAUD16 1.1.4RC6 + UNIAUD32 1.1.4RC2

Changed 11 years ago by guest

Debug info running about "somewhat working" UNIAUD16 1.1.4RC6 + UNIAUD32 1.1.4RC2

comment:1 Changed 11 years ago by guest

PS: The file called debuginfo_RC2_194.zip is badly named and poorly described. The correct name should be DEBUGINFO_RC6_194.ZIP, described as "Debug info about "working but mute" UNIAUD16 1.1.4RC6 + UNIAUD32 1.9.4". I found no way to delete and attachment so I could correct these data. Sorry. :)

comment:2 Changed 11 years ago by gentux2

  • Cc gentux2 added
  • Milestone set to HDA
  • Version changed from 1.1.4RC6 to 1.9.4

The trap in 1.1.4RC3-6 is technically a regression, so it is probably worth it for me to have a look at trying to fix that in 1.1.4. However, since this is HDA, and since even 1.1.4RC2 does not work well, it would be a lower priority than the other 1.1.4 regressions I'm working on.

I would chase this in Paul's 1.9.x development for now, but after I've caught up on the other 1.1.4 tickets I'll revisit this in 1.1.4, if he doesn't get to it first.

comment:3 Changed 11 years ago by gentux2

  • Cc gentux2 removed

This will need to be fixed in 2.0, not 1.1.4. I have dropped all HDA support for 1.1.4RC7. This ticket made me hesitate, but after reading again carefully it is clear it never worked properly, so keeping the support in 1.1.4 is not going to help anything.

comment:4 Changed 11 years ago by lewisr

I am not seeing this on the Intel DG31PR system board with the ALC888 codec. Using RC6 + 1.9.6, system sounds will hang the desktop at startup (possible overlap of events?), but if system sounds are off, the system will run normally and produce good quality output otherwise.

The way I see this, it could be one of three possibilities:

  • an ACPI issue
  • an issue related to the difference in codecs (though ALSA 1.0.17 did implement a number of fixes for Intel HDA and a number of realtek codecs, including the 662 and the 888)
  • a CPU issue (comes back to my point about ACPI, most likely)

I have tested this under 3.09 and 3.10 builds of ACPI, SMP kernel, with /SMP /APIC on the PSD line. Alternatively, this issue could be related to the quad core CPU (see next paragraph).

It should also be noted that (on this system, at least) Uniaud must be loaded after GenMAC or high utilization is apparent on the first CPU core (65% and above). Multiple boots seem to have proven that point (this is a Core Duo, but I just got done configuring a Core 2 Duo with the same system board, and observed the same behavior).

Anyway, just some more stuff to throw into the mix.

comment:5 Changed 10 years ago by psmedley

  • Resolution set to unknown
  • Status changed from new to closed

Please try with a modern version of Uniaud from http://svn.netlabs.org/uniaud and reopen the ticket if the problem persists

Note: See TracTickets for help on using tickets.