Opened 10 years ago

Closed 10 years ago

#93 closed defect (lack of feedback)

Destructions of *.tdb files

Reported by: digi Owned by: diver
Priority: blocker Milestone: Samba Server for eCS (OS/2) 1.1.0
Component: Samba Server Version: 3.0.34
Keywords: Cc:

Description

SAMBA in role PDC. Nearby 120 users and up to 50 "guests". In working hours often happen destructions of *.tdb files. The size of files %ETC%\samba\private\passdb.tdb and %ETC%\samba\private\schannel_store.tdb becomes only 4096 byte. In some minutes after restoration from backup a situation repeats. Various utilities inform on damage %ETC%\samba\lock\connections.tdb. In a reality this file appears locked (opened), and one of processes smbd.exe turns to "zombie":

C:\programs\samba>smb stop
Shutting down SMB services:
Failed to open connections database: Permission denied
Can't find pid for destination 'nmbd'
Done.
C:\programs\samba>smbstatus.exe

Samba version 3.0.34-RC11-20090526
PID     Username      Group         Machine                        
-------------------------------------------------------------------
  128   antipov       sdtu          it-16        (172.28.143.16)
<..skip..>
  132   yertner       gris          oris-138     (172.28.143.138)
C:\MPTN\ETC\samba\lock/connections.tdb not initialised
This is normal if an SMB client has never connected to your server.
Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           SharePath   Name   Time
--------------------------------------------------------------------------------------------------
145          123        DENY_NONE  0x2019f     RDWR       NONE             T:/PUB   Exchange/gris/АКТ вып. дог. обязат.Кишмишян.doc   Mon Jun 15 15:10:29 2009
<..skip..>

Change History (8)

comment:1 Changed 10 years ago by diver

the size of 4096 bytes is not necessary a broken file. as most of the new tdb files get this size.

comment:2 Changed 10 years ago by digi

Correctly, the file (connections.tdb, passdb.tdb or schannel_store.tdb) breaks, the program creates new. At essential loading files passdb.tdb and schannel_store.tdb breaks in some seconds after restoration from backups!

comment:3 Changed 10 years ago by digi

  • Resolution set to worksforme
  • Status changed from new to closed

Some programs on this computer use LIBC: samba, apache, php, mysql and other.

The problem with .tdb files is solved as follows:

  1. copy libc064x.dll to the samba's directory (my path is C:\programs\samba);
  2. start samba with next script:
set LIBPATHSTRICT=T
SET BEGINLIBPATH=C:\programs\samba
set libpath=.;%libpath%
call smb start

It seems the problem is caused by bag in libc.

comment:4 Changed 10 years ago by herwigb

Note: smb.cmd of http://svn.netlabs.org/samba/changeset/283 has BEGINLIBPATH feature added.

Note: smb.cmd of http://svn.netlabs.org/samba/changeset/299 has LIBPATHSTRICT feature added as a disabled option.

Note: set libpath=.;%libpath% is useless as LIBPATH is no environment variable.

comment:5 Changed 10 years ago by digi

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The problem has returned. But now it began to occur much less often. However, for a server it also is critical.

comment:6 Changed 10 years ago by digi

New logs:

ftp://digi.os2.snc.ru/in/smb-log.zip

events.txt in archve with timestamps

comment:7 Changed 10 years ago by diver

  • Owner changed from psmedley to diver
  • Status changed from reopened to new

comment:8 Changed 10 years ago by diver

  • Resolution set to feedback pending
  • Status changed from new to closed

wasn't that fixed with changing from jfs to hpfs?

Note: See TracTickets for help on using tickets.