Opened 10 years ago

Closed 10 years ago

#92 closed enhancem. (invalid)

mapping to subdirectory of a share

Reported by: Bartman Owned by: nobody
Priority: none Milestone: Netdrive plugin 1.5.0
Component: Samba Client Plugin Version: 3.0.34
Keywords: Cc:

Description

I checked with the developer of NetDrive?, they say this is a feature/issue for the plugin.
My Samba Server has a shared directory \data-share
\data-share has subdirecties
\data-share\data
\data-share\data\bvdata

Using the Netdrive gui,
I can create a resource for \data-share

Share field blank

I can create a resource for \data-share\data

Share field set to DATA

but I cannot create a resource for \data-share\data\bvdata

Share field set to DATA\BVDATA

error code 53

Change History (1)

comment:1 in reply to: ↑ description Changed 10 years ago by herwigb

  • Component changed from Unknown to Client
  • Milestone set to Netdrive plugin 1.5.0
  • Priority changed from blocker to none
  • Resolution set to invalid
  • Status changed from new to closed

Replying to Bartman:

Using the Netdrive gui,
I can create a resource for \data-share

Share field blank

So I guess \data-share is the only share definied on your Samba server.

I can create a resource for \data-share\data

Share field set to DATA

Ok, works as designed.

but I cannot create a resource for \data-share\data\bvdata

Share field set to DATA\BVDATA

error code 53

Which means NT_STATUS_BAD_NETWORK_NAME and which is the expected behaviour.

You have to define another share for BVDATA.

Neither IBM-LAN-Requester, nor a Windows client or even Samba's own smbclient.exe can do it the way you want to do that. For all clients known to me, you have to define a separate share on the server.

As the goal of our Samba client is to be compatible with other CIFS/SMB clients, it is very likely that nobody is going to implement such a non-trivial change in behaviour.

Besides that, if the client did work like that, it would be very time consuming, because for every mount operation the subdirectory would have to be traversed in order to find out whether you added garbage or a valid subdirectory.

That's simply not the way it is meant to work.

Note: See TracTickets for help on using tickets.