Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#9 closed defect (fixed)

Connect fails with NT_STATUS_BAD_NETWORK_NAME due to garbage characters

Reported by: guest Owned by: psmedley
Priority: major Milestone: Samba Server for eCS (OS/2) 1.0
Component: Samba Server Version: 3.0.25rc1
Keywords: connect failure garbage characters drive share Cc: herwig.bauernfeind@…

Description (last modified by herwigb)

The problem is found in 3.0.25rc1, rc2 and rc3. It was not there in 3.0.25pre2 and earlier.

When a whole drive (i.e. K:/ or K:) is shared in smb.conf AND a loglevel of 3 or 4 is defined in smb.conf, connecting to the share will fail with a NT_STATUS_BAD_NETWORK_NAME.

I have provided some logs as attachments to this ticket. Browsing the logs (search for "K:/" in the log.samba.192.168.1.3 files), you will see that it is quite obvious, why this fails, as there are garbage characters after the share name:

If the smb.conf section looks like:


[k]

path = k:/


the logfile entry at loglevel 3 or 4 will be:

[2007/04/13 17:20:15, 0] smbd/service.c:make_connection_snum(1014)

'K:/d 548 ' does not exist or permission denied when connecting to [k]

Note the the garbage after K:/ !

A workaround for this problem is either not to use loglevel 3 or 4 or use a different notation in smb.conf:


[k]

path = k:/./


Both measures make the problem go away.

Additional notes:

  • The problem does not occur with with loglevel 1, 5, 6 and 10, others not tested.
  • WinXP is sometimes able to connect successfully at the second attempt, smbclient.exe however can never connect.

Attachments (1)

logs.zip (24.4 KB) - added by guest 13 years ago.
logfiles that show the failure including used smb.conf

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by guest

logfiles that show the failure including used smb.conf

comment:1 follow-up: Changed 12 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

works with samba 3.0.25a

comment:2 in reply to: ↑ 1 Changed 12 years ago by diver

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to diver:

works with samba 3.0.25a

seems not to work 100%

comment:3 Changed 12 years ago by guest

Now that external scripts are working, this error turned into a major annoyance, because the suggested workaround (i.e. append ./ ) breaks the possibility to modify the share from (WinXP) client, because the clients gets a "does not exist" error and refuses further changes.

comment:4 Changed 12 years ago by guest

This bug is gone with my private Samba 3.0.26a build. The only difference to the official builds is that my build is built with -mcpu=athlon-mp instead of -mcpu=pentium3.

comment:5 Changed 12 years ago by guest

  • Resolution set to fixed
  • Status changed from reopened to closed

Seems to be fixed with Paul's 3.0.28 build.

comment:6 Changed 11 years ago by herwigb

  • Milestone set to Samba Server for eCS (OS/2) 1.0

comment:7 Changed 11 years ago by herwigb

  • Description modified (diff)
  • Version set to 3.0.25rc1
Note: See TracTickets for help on using tickets.