Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#42 closed defect (fixed)

SMBD.EXE crashes while browsing the resource via WPS

Reported by: ggamba Owned by: Paul Smedley
Priority: major Milestone: Samba Server for eCS (OS/2) 1.0
Component: Samba Server Version: 3.0.26a
Keywords: Cc:

Description

I'm using samba-3.0.26a-os2-20070921-v7a.wpi. In smb.conf I have

[R]

comment = Drive R: (JFS)
path = R:/[[BR]] read only = No
guest ok = Yes
hide files = /*. SF/root/

Other relevant lines are:

ea support = Yes
store dos attributes = Yes
hosts deny = ALL EXCEPT 192.168.1.

Full smb.conf is attached with logs. Most of the times, when I try to open the resource via WPS, the client desktop hangs for a while (30 seconds - 1 minute). In the log file I find:

[2007/10/21 19:06:37, 2] smbd/open.c:open_file(391)

pc1 opened file WP ROOT. SF read=Yes write=No (numopen=1)

[2007/10/21 19:06:37, 2] smbd/close.c:close_normal_file(406)

PC1 closed file WP ROOT. SF (numopen=0) NT_STATUS_OK

Killed by SIGSEGV
pid=0x007c ppid=0x006d tid=0x0001 slot=0x00ac pri=0x0400 mc=0x0001
Q:\PROGRAMS\SAMBA\SMBD.EXE
SMBD 0:0022c240
cs:eip=005b:0023c240 ss:esp=0053:0042cb20 ebp=0042cc98

ds=0053 es=0053 fs=150b gs=0000 efl=00012206

eax=01dc0000 ebx=008ce618 ecx=008ce610 edx=008ce610 edi=026e0000
esi=00920000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
/21 19:06:37, 1] smbd/service.c:close_cnum(1241)

ecs99565615 (192.168.1.10) closed connection to service R

If I enable log in Netdrive on the client, I get lot of broken pipe errors:

2007/10/28 12:54:12.44: 0 2: opening client pipe 5
2007/10/28 12:54:12.52: 0 2: Failed to read from pipe 5: 0 0
2007/10/28 12:54:12.52: 0 2: closing client pipe 5
2007/10/28 12:54:12.55: 0 2: opening client pipe 6
2007/10/28 12:54:12.63: 0 2: Failed to read from pipe 6: 0 0
2007/10/28 12:54:12.63: 0 2: closing client pipe 6

Attachments (1)

samba_logs_and_conf_07-10-23.ZIP (196.0 KB) - added by ggamba 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by ggamba

comment:1 Changed 12 years ago by Paul Smedley

Is this still present in 3.0.28?

comment:2 Changed 12 years ago by ggamba

Hi Paul,

I installed samba-3.0.28-os2-20080125-HB.zip (Herwig's build, the more recent I could find) and after some tests I can say that the problem is gone!

WPS sometimes is slow to respond while browsing Samba resources, but I think this is caused by WPS enhancers I installed together with Samba being currently slower than LAN Requester.

"Failed to read from pipe" errors are still in the client log, but they have no relation with the WPS behaviour (maybe they just increase slowness a bit).

Thanks a lot!

Gabriele

comment:3 Changed 12 years ago by Herwig Bauernfeind

Gabriele, please could you retest this with Paul's 3.0.28? The changes between Paul's 3.0.28 and my latest 3.0.28 should not affect the problem at all (as far as I can see).

comment:4 Changed 12 years ago by Paul Smedley

The crash was originally reported against 3.0.26a - so it's quite possible something got fixed in svn since which helped this bug...

comment:5 Changed 12 years ago by Paul Smedley

Resolution: fixed
Status: newclosed

comment:6 Changed 11 years ago by Herwig Bauernfeind

Milestone: Samba Server for eCS (OS/2) 1.0

comment:7 Changed 11 years ago by Herwig Bauernfeind

Version: 3.0.26a

comment:8 Changed 11 years ago by Herwig Bauernfeind

Summary: SMBD.EXE crashes while browsing the resource via WPS (version 3.0.26a)SMBD.EXE crashes while browsing the resource via WPS
Note: See TracTickets for help on using tickets.