Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#40 closed defect (duplicate)

EAs not correctly saved on Samba resource

Reported by: ggamba Owned by: Paul Smedley
Priority: major Milestone: Samba Server for eCS (OS/2) 1.0
Component: Samba Server Version: 3.0.26a
Keywords: EA Cc:

Description

I'm using samba-3.0.26a-os2-20070921-v7a.wpi. In smb.conf I have

[R]

comment = Drive R: (JFS)
path = R:/[[BR]] read only = No
guest ok = Yes
hide files = /*. SF/root/

Other relevant lines are:

ea support = Yes
store dos attributes = Yes
hosts deny = ALL EXCEPT 192.168.1.

Extended Attributes are not correctly saved on the Samba resource. See the two screenshots for a sample: the right name for the EA created by Lucide should be "LUCIDE_THUMBNAIL". Another sample: "Comments" are saved like "<strangecharacter><strangecharacter><strangecharacter>.COMMENTS" instead than just ".COMMENTS". Content of the EA seems ok but, as the EA name is wrong, the WPS can't find it.

Attachments (2)

EA_on_samba_resource.3.png (3.6 KB) - added by ggamba 12 years ago.
EA_on_local_resopurce.png (3.7 KB) - added by ggamba 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by ggamba

Attachment: EA_on_samba_resource.3.png added

Changed 12 years ago by ggamba

Attachment: EA_on_local_resopurce.png added

comment:1 Changed 12 years ago by ggamba

Resolution: duplicate
Status: newclosed

Duplicate of ticket 39

comment:2 Changed 11 years ago by Herwig Bauernfeind

Milestone: Samba Server for eCS (OS/2) 1.0

comment:3 Changed 11 years ago by Herwig Bauernfeind

Summary: EAs not correctly saved on Samba resource (version 3.0.26a)EAs not correctly saved on Samba resource
Version: 3.0.26a
Note: See TracTickets for help on using tickets.