Opened 6 years ago

Closed 6 years ago

#227 closed defect (fixed)

Timestamps set to current time when file is read

Reported by: Neil Waldhauer Owned by: Silvan Scherrer
Priority: Feedback Pending Milestone: Netdrive plugin 2.2.x
Component: Samba Client Version: Server 3.3.x
Keywords: Cc:

Description

If I read from a file on the server using REXX, the file time is set to the current time.

somefile = 'r:\somefile.txt' firstline = linein(somefile) call stream somefile, 'c', 'close'

after the call to stream, the file time is set. This is with an experimental fix provided for smbd.exe that retains file times when copying from client to server

client is eComStation with latest ndpsmb server is eComStation with experimental smbd.exe (8-16-13 2:41 5,378,052 124 smbd.exe)

Attachments (4)

testdate.cmd (1.9 KB) - added by Herwig Bauernfeind 6 years ago.
Rexx Script to test time stamp functionality for alle relevant scenarios
testdate2.cmd (2.0 KB) - added by Neil Waldhauer 6 years ago.
Testdate.cmd modified for my drive letters.
log.ndpsmb (42.9 KB) - added by Neil Waldhauer 6 years ago.
Log from running testdate2.cmd
ndpsmbtest2.zip (68.7 KB) - added by Neil Waldhauer 6 years ago.
log.ndpsmb and log.smbc from testdate2.cmd

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by Silvan Scherrer

Component: UnknownSamba Client
Milestone: Samba Server for eCS (OS/2) 1.2.xNetdrive plugin 2.2
Owner: set to Silvan Scherrer
Status: newaccepted

comment:2 Changed 6 years ago by Herwig Bauernfeind

comment:3 Changed 6 years ago by Neil Waldhauer

I have downloaded and tested the ndpsmb-testfix-Ticket227.zip and found it to solve the problem. Without the fix, the test file timestamp is updated simply by reading it. With the fix, the test file is left unaltered.

The testdate.cmd file shows the same thing.

I tested both against the new Aug 16, 2013 build of smbd.exe and the older March 18, 2013 build, and the results are the same.

Changed 6 years ago by Herwig Bauernfeind

Attachment: testdate.cmd added

Rexx Script to test time stamp functionality for alle relevant scenarios

comment:4 Changed 6 years ago by Herwig Bauernfeind

ftp://ftp.netlabs.org/pub/samba/client/test/ndpsmb-215-testfix2-Ticket227.zip This one has all timestamp scenarios working. If nothing shows up, this code will be released as 2.1.5 GA.

comment:5 Changed 6 years ago by Neil Waldhauer

Using testdate.cmd to verify the fix, I see a problem. The following error occurs every time. (I modified testdate.cmd to reflect my systems drive letters and filenames.) Other tests appear to work.

Copy over an existing file R:\temp\ndpsmbtest.txt at 07:00:37 The segment is in use by another process.

0 file(s) copied.

copy RC = 1 Create 2013-09-25 07:00:24 Access 2013-09-25 07:00:24 Write 2013-09-25 07:00:16


comment:6 Changed 6 years ago by Herwig Bauernfeind

Odd. We cannot reproduce it here, tried both EVFS and Netdrive. The errormessage does neither come from Samba, nor from cmd.exe or 4os2.exe

Which filesystems do you have in use, locally and on the server?

comment:7 Changed 6 years ago by Neil Waldhauer

I, too was puzzled by this because I have never seen this error before.

The server is eComStation 2.2 beta (eComStation 2.2 EN_US Sat May 18 10:33:28 pm 2013) It is using the experimental SMB.EXE from bug # 165. The shared drive is formatted JFS drive.

The client is eComStation 2.1 The test is run from CMD The share is set up from evfsgui (April 19, 2013)

See testdate2.cmd for my modification to the test for my drive letters.

Changed 6 years ago by Neil Waldhauer

Attachment: testdate2.cmd added

Testdate.cmd modified for my drive letters.

comment:8 Changed 6 years ago by Herwig Bauernfeind

Please retry with the latest GA Server 1.1.4, it has the fixes from ticket #165 included ftp://ftp.netlabs.org/pub/samba/server/samba-1-1-4-804.zip We have reason to believe your problem might go away.

In case it still does not work please provide log.ndpsmb collected from the testdate.cmd or your testdate2.cmd run!

Last edited 6 years ago by Herwig Bauernfeind (previous) (diff)

Changed 6 years ago by Neil Waldhauer

Attachment: log.ndpsmb added

Log from running testdate2.cmd

comment:9 Changed 6 years ago by Neil Waldhauer

I have installed SAMBA 1.1.4.B04, and re-run testdate2.cmd. There is still the one error message. I have attached log.ndpsmb.

comment:10 Changed 6 years ago by Silvan Scherrer

Priority: minorFeedback Pending

did your testdate2.cmd work with the previous client? does the copy over test work, if you only do this one and no others? please provide also the log.smbc eventually we see something more there. as we can't reproduce it.

Changed 6 years ago by Neil Waldhauer

Attachment: ndpsmbtest2.zip added

log.ndpsmb and log.smbc from testdate2.cmd

comment:11 Changed 6 years ago by Neil Waldhauer

Running testdate2.cmd causes the same error with the old client.

The copy over test gives the same error even if I only do that test (now saved as testdate3.cmd)

The logs from this restest are attached as ndpsmbtest2.zip

comment:12 Changed 6 years ago by Silvan Scherrer

Resolution: fixed
Status: acceptedclosed

please open a new ticket for that issue, as it has nothing to do with the timestamp problem anymore. i consider the timestamp problems all as fixed. a new 2.1.5 GA will be uploaded very soon.

Note: See TracTickets for help on using tickets.