Opened 5 years ago

Closed 5 years ago

#100 closed defect (fixed)

Changeset #236 breaks clients which run on codepage other than IBM-850

Reported by: herwigb Owned by:
Priority: blocker Milestone: Netdrive plugin 1.5.0
Component: Samba Client Plugin Version: NDP 1.5 beta 1
Keywords: Cc:

Description

The default setting of SYSTEM as it was before before #236 enables client systems running a different codepage than IBM-850 to work properly, while after #236 the display of national characters fails on these systems.
Patching recent ndpsmb.dll (beta1 refresh or beta2) from IBM-850 to IBM-866 makes the problem go away, which verifies this theory.
The problem is that server and client require either a different code here, or alternatively the codepage must be configurable on the client, either by its own smb.conf or by a control within the GUI.

Attachments (4)

20090511.png (5.9 KB) - added by herwigb 5 years ago.
Client before #236
20090610.png (5.8 KB) - added by herwigb 5 years ago.
Client beta1 refresh (after changeset #236)
20090709.png (5.9 KB) - added by herwigb 5 years ago.
Client beta2 (also post changeset #236)
20090709-create_file-dir.png (7.3 KB) - added by herwigb 5 years ago.
Client beta2 directory creation example.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by herwigb

Client before #236

Changed 5 years ago by herwigb

Client beta1 refresh (after changeset #236)

Changed 5 years ago by herwigb

Client beta2 (also post changeset #236)

Changed 5 years ago by herwigb

Client beta2 directory creation example.

comment:1 Changed 5 years ago by diver

fixed for the 3.0 branch in r307

comment:2 Changed 5 years ago by diver

fixed for the 3.0 branch in r308

comment:3 Changed 5 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.