Opened 6 years ago

Closed 6 years ago

#89 closed defect (not a bug)

QTbrowsers no longer work with https

Reported by: guzzi Owned by:
Priority: major Component: qtapps
Version: Keywords:
Cc:

Description

Qupzilla and Dooble browsers can no longer connect securely. This -also- goes for older versions. Something must have broken or changed in the api of whatever the browsers use for secure connections.

Change History (3)

comment:1 Changed 6 years ago by Silvan Scherrer

ok this case is more or less clear. Qt 4.7 sets SSLv3 as default, and this is not supported anymore by a lot sites. Qt 4.8 lets the server decide if he accepts TLSv1 or SSLv3.

So the port needs a: QSslConfiguration::setProtocol(QSsl::TlsV1) before any connection happens.

@Elbert: go for it

comment:2 Changed 6 years ago by Tellie

Hello,

Please try ftp://ftp.netlabs.org/pub/qtapps/QtNet4_Fix_SSL.zip

This a temporary fix.

Thankz Silvan from Bitwise for the newer DLL

comment:3 Changed 6 years ago by Silvan Scherrer

Resolution: not a bug
Status: newclosed

with a reference to http://trac.netlabs.org/qt4/ticket/296 I close that ticket.

Note: See TracTickets for help on using tickets.