Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#79 closed defect (fixed)

qbittorrent 3.1.9 cannot delete torrents

Reported by: losepete Owned by: diver
Priority: blocker Component: qtapps
Version: Keywords:
Cc:

Description

Having completed downloading a torrent and failed to download 3 other torrents I selected all 4 torrents and *deleted* them.

I then closed qbittorrent.

A little later I restarted qbittorrent and the 4 previously deleted torrents appeared onscreen as though they had not been deleted.

To check I was not going a little senile/forgetful I deleted the torrents again, closed qbittorrent and restarted it again after around 15 minutes.

The 4 deleted torrents reappeared.

I deleted the 4 torrents again, closed qbittorrent and deleted all the ini files in %HOME%\.config\qbittorrent

I then restarted qbittorrent and the 4 previously deleted torrents reappeared!

Obviously there is something wrong with this build of qbittorrent - I have never had problems deleting torrents previously.

Also it seems that qbittorrent is now hiding a configuration file somewhere else on my system otherwise it would not be able to load the previously deleted torrents. Where does qbittorrent now hide configuration files?

Change History (10)

comment:1 Changed 6 years ago by diver

  • Owner set to diver
  • Status changed from new to accepted

comment:2 Changed 6 years ago by diver

we tried several versions and all failed the same way. So I wonder which version worked last for you ok.

comment:3 Changed 6 years ago by jep

Delete the files in: C:\HOME\DEFAULT\.local\share\data\qBittorrent\BT_backup\ The problem is extremly annoying

Jan-Erik

comment:4 Changed 6 years ago by diver

I know it's annoying now. I wasn't aware of that problem until this ticket was created. I'm searching for a fix now.

comment:5 Changed 6 years ago by diver

please redownload latest qbit 3.1.9. It should work now.

comment:6 Changed 6 years ago by diver

  • Resolution set to fixed
  • Status changed from accepted to closed

latest qbit fixes this bug

comment:7 Changed 6 years ago by jep

Just downloaded the new version of qbittorrent 3.1.9 and it still cannot delete the actual torrents from the backup-path "C:\HOME\DEFAULT\.local\share\data\qBittorrent\BT_backup\". The option to delete the downloaded files do work It leave the torrent files behind so they'll reappear when you restart qbittorrent.

Last edited 6 years ago by jep (previous) (diff)

comment:8 Changed 6 years ago by diver

only new added torrents are deleted, as the old ones had a hash name problem. so when you delete everything from BT_backup and add a new torrent and delete it. is must be deleted. at least here and for testers it works 100%.

and please do me a favour: when you want support don't write "!" in your comments.

comment:9 Changed 6 years ago by jep

Thank you.

I'll keep that in mind

comment:10 Changed 6 years ago by jep

I can confirm that this has been resolved with the re-release of qBittorrent 3.1.9

  1. The additional information you provided, to delete previous files by hand, did it.
  2. It delete all selected files hereafter in the folder BT_Backup
  3. It can handle it even if the home directory reside on another drive

Thank you for the provided information about the hash name.

Jan-Erik Software Tester for MONITOR ERP System An ERP System for small to medium sized manufacturing companies

Note: See TracTickets for help on using tickets.