Opened 13 years ago

Closed 12 years ago

#7 closed defect (worksforme)

psi uses 100% of CPU

Reported by: pr Owned by: dmik
Priority: blocker Component: psi
Version: psios2-0.10.1 Keywords: 100% CPU load
Cc:

Description

psi uses 100% of CPU and cripples the system, making everything else run slowly. I expect it is polling something and not designed the way PM apps. ought to be designed.

Change History (7)

comment:1 Changed 13 years ago by dmik

  • Keywords 100% CPU load added

Thanks for the report, but could you please be little bit more descriptive? In particular:

  1. What do you exactly do with Psi when it happens?
  2. Which jabber server do you use?
  3. What do you need to do in order to restore normal system behavior?
  4. Is this problem always and easily reproducible?
  5. What OS/2 version do you have?

From what I can guess, it may happen if you use GPG. Or if you use some specific jabber server that produces heavy XML traffic in certain places (for example when browsing services).

Other than that, I cannot recall anything that uses the polling technique in Qt. There may be a Psi (i.e. not Qt) issue that I'm not aware of (I haven't studied Psi sources that well).

comment:2 Changed 13 years ago by dmik

Just got a thought that your problem may be related to sounds. Please try to turn off sounds (Main Menu -> Play Sounds) and see if the problem has gone. Also try the workaround described in the Troubleshooting section of Readme-OS2.txt (don't forget to turn sounds on again to see the effect) and report here about the result. See also ticket:5.

comment:3 Changed 13 years ago by eros2

I experience 100% CPU load sometimes. I have Jabber account with ICQ transport and many ICQ contacts. Sometimes (very rare, however) when I login with this account Psi loads contact list and also loads CPU. Psi works, but looking in WatchCat? one thread always in "running" state. When I switch account to offline - CPU load is gone.

This happens rare and not a big problem, I just preform relogin.

comment:4 Changed 13 years ago by guest

Hi dmik,

I had a similar problem on my desktop pc, while I did not have it on my laptop. I have now discovered that the desktop pc (100% CPU) was using warp kernel, while the laptop had SMP kernel (for an error, I guess, as it doesn't have 2 cpus). The laptop with the SMP kernel, on the other hand, had troubles with mozilla based applications that was cured with the

SET NSPR_OS2_NO_HIRES_TIMER=1

setting in config.sys.

comment:5 Changed 13 years ago by dmik

In the eros2 case, it may be a problem of the TCP/IP stack (since it is most likely the select() thread that gives 100% load). I experienced something similar when working on OpenPGP, see http://svn.netlabs.org/qtapps/ticket/6.

Regarding the last comment, I cannot say anything; too few information. As an assumption, check that you don't have gpg[.exe|.cmd] in PATH (which may give 100% load as well, see the above ticket).

comment:6 Changed 13 years ago by guest

Hi Dmik,

I'm the one that created http://svn.netlabs.org/qtapps/ticket/6, so I know it very well :-) The problem presenting on one machine and not on another one I'm referring to in "10/05/06 16:12:42" message is the same that was cured using the warp version of the kernel instead of the smp one. So, currently, the problem doesn't appear anymore on any system!

Bye and thanks Gabriele

comment:7 Changed 12 years ago by dmik

  • Resolution set to worksforme
  • Status changed from new to closed

I'm closing this as the reporter is happy so far.

Note: See TracTickets for help on using tickets.