Opened 6 years ago

Closed 5 months ago

#66 closed defect (wontfix)

Juffed hangs after search and save

Reported by: estellnb Owned by:
Priority: major Component: qtapps
Version: Keywords:
Cc:

Description

by executing the following commands I have a reproducible WPS-hang which can only be resolved by terminating JuffEd? (eCs 2.2):

  • [f:\apps\juffed]juffed.exe h:InstallUpdate.html
  • change Charset to UTF-8
  • search for "usbhcd"; double click on the result
  • change something
  • save the results

just opening a document; setting the charset to utf-8 and saving does not hang juffed; CPU usage remains at 100% when the hang occurs.

Change History (7)

comment:1 Changed 6 years ago by estellnb

well it hangs on any save (as soon as there are some changes).

comment:2 Changed 6 years ago by estellnb

Oops; LIBPATH was not set correctly. Seems as the program does a chdir and then attempts a 'DosLoadModule?' whereby the dlls are then no more on path. Works with correct LIBPATH; dll-loading is however an error it should probably check for as I believe.

Last edited 6 years ago by estellnb (previous) (diff)

comment:3 Changed 6 years ago by estellnb

Last edited 6 years ago by estellnb (previous) (diff)

comment:4 Changed 6 years ago by estellnb

You have distributed that as a .wpi. I would suggest the rexx-warpin script to set LIBPATH and DPATH as some options are not even available without DATAPATH set to the juffed directory as f.i. charset selection.

Last edited 6 years ago by estellnb (previous) (diff)

comment:5 Changed 6 years ago by estellnb

Sometimes the "select charset" feature is here; sometimes it is not. strange; has nothing to do with dpath; however this way I can not use this editor because its system default setting does not default to UTF-8. Disabling all other charsets in settings does not help either. Too bad; would have been a nice editor! System default should be UTF-8 on eCs 2.2, shouldn´t it?

Last edited 6 years ago by estellnb (previous) (diff)

comment:6 Changed 6 years ago by estellnb

Well; that it loads with System default charsets if all other charsets but UTF-8 are disabled is likely a bug of juffed itself; will additionally report that to the primary developer. However eCs should set the system default charset correctly; I guess; and then there is the error of the disappearing View->Select Charset menu entry.

comment:7 Changed 5 months ago by Tellie

Resolution: wontfix
Status: newclosed

I close this ticket as its silence for 6 years.

Note: See TracTickets for help on using tickets.