Opened 6 years ago

Closed 3 years ago

#62 closed defect (not a bug)

PSI crash

Reported by: andib Owned by:
Priority: Feedback Pending Component: psi
Version: Keywords:
Cc:

Description

PSI message box showed something like "Zertifikat xxx ist nicht vertrauenswürdig, Trotzdem verbinden, Vertrauen, Abbrechen". After clicking "Trotzdem verbinden" PSI crashed -

##################################
 Date: 2013-08-29  Time: 20:08:25
##################################

[20:08:26] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[20:08:31] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[20:08:31] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGSEGV
pid=0x006f ppid=0x0027 tid=0x0001 slot=0x00a6 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
PSI 0:004406ca
cs:eip=005b:004506ca      ss:esp=0053:00ef65bc      ebp=00ef65d4
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010212
eax=00000000 ebx=00000000 ecx=1bc00002 edx=2003013c edi=00ef66cc esi=00000001
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Unfortunately not reproducibly as the second time I clicked "Vertrauen" which worked and now the dialog does not show up again.

Change History (14)

comment:1 Changed 6 years ago by andib

Crashes while no user intervention -

##################################

Date: 2013-10-18 Time: 11:06:14

##################################

[11:06:15] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune [11:06:16] W:Custom authentication realm not used

Killed by SIGSEGV pid=0x0071 ppid=0x0027 tid=0x0001 slot=0x00a6 pri=0x0200 mc=0x0001 P:\UTIL\PSI0.15\PSI.EXE PSI 0:004406ca cs:eip=005b:004506ca ss:esp=0053:00efe428 ebp=00efe440

ds=0053 es=0053 fs=150b gs=0000 efl=00010206

eax=00000000 ebx=00000000 ecx=1bc00002 edx=2003013c edi=00efe538 esi=00000001 Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

##################################

Date: 2013-10-19 Time: 09:06:31

##################################

[09:06:32] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune [09:06:33] W:Custom authentication realm not used [09:06:36] W:PEPAvatar::setData(): Received data is empty. Bad encoding ? [09:19:07] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE pid=0x0075 ppid=0x002a tid=0x0001 slot=0x00aa pri=0x0200 mc=0x0001 P:\UTIL\PSI0.15\PSI.EXE QTCORE4 0:001b0dd4 cs:eip=005b:1d3a0dd4 ss:esp=0053:00effd00 ebp=00effdb8

ds=0053 es=0053 fs=150b gs=0000 efl=00010246

eax=00750001 ebx=2003c7e0 ecx=00000024 edx=00000000 edi=00effd5c esi=00000000 Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Last edited 6 years ago by andib (previous) (diff)

comment:2 Changed 6 years ago by diver

please provide the date of your qtcore4.dll

comment:3 Changed 6 years ago by andib

Latest qt4 rpm packages.

22.03.13  17.58       1.676.690    124   ___A_  QtCore4.dll
{0}[m:\] bldlevel "P:\usr\lib\QtCore4.dll"
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature: @#Nokia:4.7#@##1## 22 Mar 2013 17:58:23 :T_BUILD_ID:::3::@@Qt4: C++ application development framework. Copyright (C) 2011 Nokia Corporation and/or its subsidiary(-ies).
Vendor: Nokia
Revision: 4.07
Date/Time?: 22 Mar 2013 17:58:23
ASD Feature ID: T_BUILD_ID
File Version: 4.7.3
Description: Qt4: C++ application development framework. Copyright (C) 2011 Nokia Corporatio

comment:4 Changed 6 years ago by diver

  • Priority changed from major to Feedback Pending

thats the latest. I have no idea why this happens, as i never saw that with the latest Qt4. If you can reproduce it somehow, we can have a further look.

comment:5 Changed 6 years ago by diver

did you already try psi 0.16 build?

comment:6 Changed 6 years ago by andib

Yes, since about one month. Although I did not rename the directory from 0.15 these crashes were with v0.16 (Psi v0.16-dev-20130823 on eComStation 2.1). Problem is I do not know how to reproduce. On the other hand I hardly use PSI. It's only running in the background whenever I start my system.

##################################
 Date: 2013-10-31  Time: 19:03:37
##################################

[19:03:38] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[19:03:39] W:Custom authentication realm not used
[19:03:42] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x0079 ppid=0x0027 tid=0x0001 slot=0x00b4 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3c0dd4      ss:esp=0053:00fcfcd0      ebp=00fcfd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00790001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00fcfd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
##################################
 Date: 2013-11-02  Time: 17:51:13
##################################

[17:51:47] W:QObject::connect: Cannot connect (null)::resolve_resultsReady(int,QList<XMPP::NameRecord>) to XMPP::NameManager::provider_resolve_resultsReady(int,QList<XMPP::NameRecord>)
[17:51:47] W:QObject::connect: Cannot connect (null)::resolve_error(int,XMPP::NameResolver::Error) to XMPP::NameManager::provider_resolve_error(int,XMPP::NameResolver::Error)
[17:51:47] W:QObject::connect: Cannot connect (null)::resolve_useLocal(int,QByteArray) to XMPP::NameManager::provider_resolve_useLocal(int,QByteArray)

Killed by SIGSEGV
pid=0x0063 ppid=0x001d tid=0x0001 slot=0x0099 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
PSI 0:00490aeb
cs:eip=005b:004a0aeb      ss:esp=0053:00fcec30      ebp=00fcec88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00000000 ebx=20448860 ecx=00000000 edx=2003013c edi=00000000 esi=00000002
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
##################################
 Date: 2013-11-08  Time: 18:34:17
##################################

[18:34:18] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[18:34:19] W:Custom authentication realm not used
[18:34:21] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[18:43:51] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[18:43:51] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[18:45:34] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x0071 ppid=0x0027 tid=0x0001 slot=0x00a6 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3a0dd4      ss:esp=0053:00fcfcd0      ebp=00fcfd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00090246
eax=00710001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00fcfd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
##################################
 Date: 2013-11-12  Time: 10:31:58
##################################

[10:31:59] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[10:32:02] W:Custom authentication realm not used
[10:32:05] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
......
[10:49:32] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x0074 ppid=0x002a tid=0x0001 slot=0x00aa pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d390dd4      ss:esp=0053:00fcfcd0      ebp=00fcfd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00740001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00fcfd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
##################################
 Date: 2013-11-20  Time: 21:30:24
##################################

[21:30:25] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[21:30:27] W:Custom authentication realm not used
[21:30:30] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[21:34:01] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[21:50:33] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x0079 ppid=0x0027 tid=0x0001 slot=0x00b4 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3e0dd4      ss:esp=0053:00fcfcd0      ebp=00fcfd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00790001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00fcfd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.
##################################
 Date: 2013-11-24  Time: 10:52:42
##################################

[10:52:43] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[10:52:44] W:Custom authentication realm not used
[10:52:47] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x007b ppid=0x002a tid=0x0001 slot=0x00b8 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.15\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3e0dd4      ss:esp=0053:00fcfcd0      ebp=00fcfd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=007b0001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00fcfd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Nearly all crashes are at QTCORE4 0:001b0dd4

Last edited 6 years ago by andib (previous) (diff)

comment:7 Changed 6 years ago by andib

Another one with latest PSI -

####### v0.16-dev 20131206 #######
 Date: 2013-12-31  Time: 13:52:48
##################################

[13:52:49] W:QFileSystemWatcher: failed to add paths: e:/HOME/DEFAULT/.cache/psi/tune
[13:52:49] W:Custom authentication realm not used
[13:52:51] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[13:52:52] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[13:53:44] W:QWebInspector: QSettings couldn't read configuration setting [resourceTrackingEnabled].

Killed by SIGFPE
pid=0x00f0 ppid=0x0027 tid=0x0001 slot=0x0072 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.16\PSI.EXE
QTGUI4 0:00206536
cs:eip=005b:1c656536      ss:esp=0053:00f3e65c      ebp=00f3e65c
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010202
eax=217e5ff4 ebx=217e5fe0 ecx=217e5fe0 edx=2003013c edi=202bc910 esi=00f3e7dc
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

This one was while updating "Visitenkarte" in Profile. Seems while transmitting the new data over the network.

comment:8 Changed 6 years ago by andib

Again with latest PSI version at the well known place - QTCORE4 0:001b0dd4

This time I didn't do anything with PSI. It just runs in the background as the window suddenly disappeared. Maybe hovering over with the mouse which sets the focus on it (xwp sliding focus).

####### v0.16-dev 20131206 #######
 Date: 2014-01-03  Time: 11:05:00
##################################

[11:05:01] W:Custom authentication realm not used
[11:05:04] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[11:05:04] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?

Killed by SIGFPE
pid=0x0074 ppid=0x002a tid=0x0001 slot=0x00a6 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.16\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3c0dd4      ss:esp=0053:00f3fcd0      ebp=00f3fd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00740001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00f3fd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

I have another crash at the same location again. This time Seamonkey was heavily working with JavaScrips? I guess as it made the whole WPS very unresponsive. At least after unchecking JavaScript? in PrefBar? the system load drops down.

Maybe this problem only occurs while the system is heavily stressed.

Last edited 6 years ago by andib (previous) (diff)

comment:9 Changed 6 years ago by andib

Just for the record the newest PSI version crashes at the same well known address. This time when I selected RMB - Status - online.

####### v0.16-dev 20131206 #######
 Date: 2014-02-28  Time: 19:20:03
##################################

[19:21:27] W:Custom authentication realm not used

Killed by SIGFPE
pid=0x0072 ppid=0x002a tid=0x0001 slot=0x0054 pri=0x0200 mc=0x0001
P:\UTIL\PSI0.16\PSI.EXE
QTCORE4 0:001b0dd4
cs:eip=005b:1d3c0dd4      ss:esp=0053:00f3fcd0      ebp=00f3fd88
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=00720001 ebx=2003c8c0 ecx=00000024 edx=00000000 edi=00f3fd2c esi=00000000
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

comment:10 Changed 6 years ago by diver

as I can't reproduce it locally you need to life with that until we add exceptq to Qt4.

comment:11 Changed 6 years ago by diver

the SIGFPE seems like a global problem now. We also have several reports that our Firefox crashes with SIGPFE. We are trying to do a general solution.

comment:13 Changed 3 years ago by andib

These SIGFPE crashes are gone here since I installed Holgers kernel patches. I just checked the log and since about 3 week no single crash. Before I had about 4 crashes a week.

LuckyBackup? didn't crash too since then. So either there was some libc changes which cured the problem or this all is a SNAP/kernel/pmmerge issue that Holger fixed. Unfortunately after my holidays at end of August/beginning of September I made 'yum update' and installed Holgers patches at the same time. So I'm not sure which of these cured the problem.

comment:14 Changed 3 years ago by diver

  • Resolution set to not a bug
  • Status changed from new to closed

Thx for the update. I close the issue then.

Note: See TracTickets for help on using tickets.