Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#57 closed defect (no response)

Using qpdfview_0_4_1.zip when I try to open a pdf file I get a message that it can not load the PDF plugin.

Reported by: axdmlm Owned by: diver
Priority: Feedback Pending Component: qpdfview
Version: Keywords: PDF plugin
Cc:

Description (last modified by diver)

I downloaded Qpdfview_0_4_1.zip and unzipped it into a directory. When I attempt to open a PDF it fails with a message could not load PDF plugin. I ran chkdll32 against the qpdfview.exe and here is the output.

[I:\Qpdfview]chkdll32 qpdfview.exe
Loading DLL 'libc065' --> I:\ECS\DLL\LIBC065.DLL.
Loading DLL 'QtCore4' --> I:\USR\LIB\QTCORE4.DLL.
Loading DLL 'stdcpp' --> I:\ECS\DLL\STDCPP.DLL.
Loading DLL 'QtGui4' --> I:\USR\LIB\QTGUI4.DLL.
Loading DLL 'gcc446' --> I:\ECS\DLL\GCC446.DLL.
Loading DLL 'cups' --> I:\CUPS\SBIN\CUPS.DLL.
Loading DLL 'QtSql4' --> I:\USR\LIB\QTSQL4.DLL.
Loading DLL 'z' --> I:\USR\LIB\Z.DLL.
Loading DLL 'tcpip32' --> I:\MPTN\DLL\TCPIP32.DLL.
All DLL's used by 'qpdfview.exe' could be loaded.

Change History (15)

comment:1 Changed 6 years ago by diver

  • Description modified (diff)
  • Priority changed from major to Feedback Pending

first of all use newest qpdfview, which is 0.4.2 and also loot at the readme to verify you have all needed dll.
and yes qpdfview.exe could load everything, that's why it runs. but when opening a pdf qpdfpdf.dll gets loaded. and it seems something is missing for that.
try to redirect the output to a file like qpdfview.exe > out.txt. if this file is empty try qpdfview.exe 2> out.txt

comment:2 Changed 6 years ago by diver

  • Description modified (diff)

comment:3 Changed 6 years ago by axdmlm

I would like to download 0.4.2 but when I click on the zip file Firefox gives me a 505 failed to change directory message. I am using Ecs 2.2 beta. I tried to open a bug on Ecs but they told me to open a ticket here. Firefox is 10.0.11.

comment:4 Changed 6 years ago by axdmlm

Sorry wrong message. The Error message is 550 failed to change directory.

comment:5 Changed 6 years ago by diver

thx for letting me know. the link is fixed.
and sure this ticket belongs here, as ecs has absolutely nothing to to with qtapps port.

comment:6 Changed 6 years ago by diver

any news about that ticket?

comment:7 Changed 6 years ago by diver

please use pmdll from hobbes and see if all dll for qpdfpdf.dll can be loaded.

comment:8 Changed 6 years ago by diver

  • Resolution set to no response
  • Status changed from new to closed

hmm no response for 3 weeks. so i close it.

comment:9 Changed 6 years ago by axdmlm

I have tried to use PMDLL with QPDFVIEW.EXE and it gives me this message:PMDLL Tree View File is not a DLL or executable. ('LX'). I do not know what this means but the program actually does appear to run, but can not load the PDF Plugin. My original report included the output from the ChkDll32 program and it indicates that all dll's can be loaded. See the original report. I don't have an explanation for this, but I am using the ECS 2.2 beta which is supposed to have the QT libraries already installed.

Chkdll32 says: All DLL's used by 'qpdfview.exe' could be loaded.

comment:10 Changed 6 years ago by axdmlm

I don't know what is with the version 2.34 of PMDLL, but I tried version 2.11 and it does give me a DLL tree. It reports no load failures. I do not know how to send a copy of the output, since the program does not create a report file.

comment:11 Changed 6 years ago by diver

i wrote in comment 8 that you need to see if all dll for qpdfpdf.dll are loaded. that all for qpdfview.exe works we know, as other wise it would not load.

comment:12 Changed 6 years ago by axdmlm

CHKDLL32 says this: [I:\Qpdfview]chkdll32 qpdfpdf.dll File is not a valid OS/2 .EXE or .DLL file

PMDLL does not report any errors but there are lots of DLLs and no convenient way to list the output from that program.

comment:13 Changed 6 years ago by axdmlm

EXEHDR reports this: Operating System/2 Executable File Header Utility Version 3.00.002 May 4 1995 Copyright (C) IBM Corporation 1988-1995 Copyright (C) Microsoft Corp. 1988-1992. All rights reserved.

Library: qpdfpdf Description: @#bww bitwise works GmbH:0.4#@##1## 25 Apr 2013 17:59:08

:beta1:::2::@@eCS (OS/2) port of qpdfview by Adam Reichold

Module type: Dynamic link library

Per-process initialization Per-process termination NO internal fixups in executable image

Number of memory pages: 0000000d (13) Initial CS:EIP: object 1 offset 00000000 Initial SS:ESP: object 0 offset 00000000 Automatic data object: 2

no. virtual virtual map map flags

address size index size

0001 00010000 000095c0 00000001 0000000a EXECUTABLE, READABLE, 32-bit 0002 00020000 000024a0 0000000b 00000003 READABLE, WRITEABLE, 32-bit

Exports: ord obj offset name

1 1 00003f90 qt_plugin_instance exported 2 1 00000350 qt_plugin_query_verification_data exported

comment:14 Changed 6 years ago by axdmlm

Finally I can read PDFs. I tried the qpdfview-0_4_3-beta1.zip and it does work.

comment:15 Changed 6 years ago by diver

ok good.

Note: See TracTickets for help on using tickets.