Opened 6 years ago

Closed 6 years ago

#55 closed defect (invalid)

printing problems

Reported by: vrwp Owned by: diver
Priority: Feedback Pending Component: qpdfview
Version: Keywords:
Cc:

Description

using qpfview 0.4.0 gives the following problem: document with 4 pages only the first 2 are printed. document with 25 pages only pages from 1 up to 24 are printed, page 25 not. No error messages at ecups.

Attachments (1)

error_log.zip (68.2 KB) - added by vrwp 6 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by vrwp

Tried version 0.4.2 beta1 problem keeps the same, always the latest page won't print. Even with a pdf document with 2 pages, page1 prints, but not page 2. Tried with duplex and without duplex printing. If I try to print only the latest page, nothing comes out of the printer, cups says it has printed something without mentioning the pages (unkown)

comment:2 Changed 6 years ago by diver

  • Priority changed from major to Feedback Pending

do other apps print ok? also using cups of course.

comment:3 Changed 6 years ago by vrwp

Tried it with an os/2 application, using the ecups driver, no problem. tried it with goodword, print preview shows 2 pages, only first is printed. ecups shows in the administration tab also 1 page, also same problem as with qpdf.

comment:4 Changed 6 years ago by diver

so this means it's not a qpdfview problem. i now wonder if cups still has problems with printouts from qt.
what cups version do you have? especially the date of cups.dll. and make sure you have only one cups.dll around.

comment:5 Changed 6 years ago by vrwp

only have 1 cups.dll (checked :-) ) date 04-11-2012 00:41 installed cups version with wpi (version 1_4_8_3

comment:6 Changed 6 years ago by diver

when you higher the error level in cups, the pdf files gets saved. please try to open such a saved file and see if everything is there.

Last edited 6 years ago by diver (previous) (diff)

Changed 6 years ago by vrwp

comment:7 Changed 6 years ago by diver

this seems like a cups problem to me. please open a ticket at Paul Smedley's bugtracker with a reference to this ticket.

comment:8 Changed 6 years ago by psmedley

try replacing \cups\bin\pdftops.exe with the one at http://smedley.id.au/tmp/pdftops.zip

The issue is that libc doesn't flush pipes before they are closed, which can result in missing data. Other filters have needed a fflush(stdout) before the pipe is closed to fix similar issues. Same fix appears to fix pdftops.exe too.

Tested as fixing PDF printing here.

comment:9 Changed 6 years ago by vrwp

Tried it, but get error message: stopped "/cups/lib/cups/filter/pdftops.exe failed"

I replaced pdftops.exe in cups\bin and in cups\lib\cups\filter\ I hope I didn't made a mistake in doing that.

comment:10 Changed 6 years ago by psmedley

the two pdftops.exe in \cups\bin and \cups\lib\cups\filter are completely different. only replace the one in \cups\bin

comment:11 Changed 6 years ago by diver

  • Resolution set to invalid
  • Status changed from new to closed

according to Paul's bugtracker this issue is resolved.
i mark it as invalid, as it was not qpdfview bug.

Note: See TracTickets for help on using tickets.