Opened 7 years ago

Closed 7 years ago

#41 closed defect (fixed)

psi 0.15 - "qcatls2.dll is not a valid Qt plugin"

Reported by: infinity Owned by:
Priority: Feedback Pending Component: qtapps
Version: Keywords:
Cc:

Description

Installed 0.15 - upgrade from 0.10 worked fine - just the security plugin does not want to load

Diagnostic says:

qcatls2.dll: failed to load: The file 'G:/PSI/crypto/qcatls2.dll' is not a valid Qt plugin.

Change History (8)

comment:1 Changed 7 years ago by tellie

Hi,

Did you use the dll that came with the programme ?

Also it's better to use dir structure as it's in the zip file.

comment:2 Changed 7 years ago by Silvan Scherrer

Priority: majorFeedback Pending

did you really exchange all files? qcatls2.dll is from 23.10.2012. if yours is different, please update it.

comment:3 Changed 7 years ago by infinity

Yes I used the dll that came with the program. I did not have any earlier version before either. The file is dated 23.10.2012. And regarding the dir structure - it definitely finds the file - I don't get the message if I remove it.

comment:4 Changed 7 years ago by Silvan Scherrer

and openssl is also installed? as it needs openssl.

comment:5 in reply to:  4 Changed 7 years ago by infinity

Have installed it now (copied dlls and exe to appropriate os2 dirs). But does not help. Is that an additional requirement compared to 0.10?

comment:6 Changed 7 years ago by Silvan Scherrer

did you carfully read the psi readme? i mean all requirements are written there. which openssl did you install? as i don't think there are exe files for openssl >= 1.0.x

comment:7 Changed 7 years ago by Silvan Scherrer

i just see that the readme doesn't mention openssl. please install it with "yum install openssl" or download it from http://rpm.netlabs.org/release/00/zip and install the dll to your libpath.

i adjusted the the readme now and the next upload will also have that information.

comment:8 Changed 7 years ago by Silvan Scherrer

Resolution: fixed
Status: newclosed

readme changed in upload from today. it if still does not work with the correct openssl, please reopen the ticket.

Note: See TracTickets for help on using tickets.