Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#126 closed defect (fixed)

QPDFView fails to start

Reported by: losepete Owned by:
Priority: blocker Component: qtapps
Version: Keywords:
Cc:

Description

Seems qpdfview 4.15 has to find CUPS.DLL installed before it will even start.

This is a problem as I have CUPS installed from zip files and there is no CUPS.DLL file involved - there is a CUPS20.DLL instead.

No, I will not be trying qpdfview 4.17-6beta2 as that actually wants to download and install the rpm CUPS packages which are simply not required.

So, qpdfviewer needs to be a little reworked to accept the CUPS20.DLL supplied in the CUPS2.x zip releases.

Change History (3)

comment:1 Changed 4 months ago by losepete

I have discovered that placing a copy of CUPS20.DLL as CUPS.DLL into the directory containing qpdfview.exe enables the application to actually start - seems qpdfview.exe does not check LibPath? where it would have found the same CUPS.DLL.

Having got qpdfview running I then find it is totally useless as it cannot open any files; attempting to open any PDF file results in an error message along the lines of "Cannot find PDF plugin".

This would be the qpdfpdf.dll file in the same directory as qpdfview.exe I suspect.

Obviously lots more work needed on qpdfview before it is useful in any way.

comment:2 Changed 4 months ago by Silvan Scherrer

Resolution: fixed
Status: newclosed

qpdfview works exactly as designed. If you don't want to use the rpm env it's on you. But qpdfview will always only work in a rpm env with rpm based dll. as cups2.dll is old and not rpm based.

as this is a permanent restriction I close this ticket.

comment:3 Changed 4 months ago by losepete

Following advice on os2world.com - see discussion https://www.os2world.com/forum/index.php/topic,2227.0.html - I re-read install.os2, double checked that all required libraries are in place and finally deleted %HOME%/.config/Trolltech.ini

Now qpdfview runs and can open and print PDF files, looks like that ini file was the cause of problems all along.

Note to self: Must read and pay attention to instructions in install/readme files.

However, the fact qpdfview 4.17-6beta2 now works fine and prints via non-rpm cups disproves your above statement "qpdfview will always only work in a rpm env with rpm based dll. as cups2.dll is old and not rpm based." No, cups20.dll from cups v2.1.0 is not so much old as ported to not need an rpm environment. I must admit to having a lot of support libraries installed via ANPM(yum/rpm) and do appreciate the work that BWW put in to keeping OS/2 a viable platform.

Note: See TracTickets for help on using tickets.