Opened 13 years ago

Closed 12 years ago

#1 closed defect (wontfix)

Psi doesn't work correctly with the built-in OS/2 SOCKS client

Reported by: Sergey Owned by: dmik
Priority: major Component: psi
Version: psi-0.10-os2-b1 Keywords: socks
Cc:

Description (last modified by dmik)

psi doesnt connect if OS/2 builtin socks client enabled.

also its not possible to send files while socks server enabled in PSI connection config for account.

[Ticket comments are copied from http://svn.netlabs.org/qt3/ticket/25]

Change History (9)

comment:1 Changed 13 years ago by Sergey

  1. Builtin socks:
            %ETC%\socks.cfg
            %ETC%\socks.env
    

socks.cfg (sample)

        direct 192.168.0.0 255.255.0.0
        direct 10.0.0.0 255.0.0.0
        direct 195.12.0.0 255.255.0.0
        direct 62.177.0.0 255.255.0.0
        direct 82.195.0.0 255.255.0.0
        sockd @=62.33.x.x 0.0.0.0 255.255.0.0 *= *=

socks.env (sample)

        socks_flag on
        socks_user
        socks_password
        socks_server 62.33.x.x
        socks_domain sample.dom
        socks_ns 62.177.x.x

Specify in SPI setup "Proxy:none" and you should see no connection to jabber server. Jeti/2 does using this config.

  1. Setup socks proxy in account settings. Use it in "Connection" for your jabber account.

Try to send/recv file to/from any jabber user in yr list. Here I cant success with it. Jeti/2 does perfectly.

Im behind firewall.

comment:2 Changed 13 years ago by dmik

Sergey, can you please try some other app using libc061.dll through your socks? For example, the SVN client (http://www.smedley.info/os2ports/subversion.html). To be sure the proble is in Qt, not in libc.

Also, have you tried PSI/2 Alpha 1? Does it not work too?

comment:3 Changed 13 years ago by Sergey

The problem appear only with OS/2 builtin socks client. Cant reproduce this err on win.

comment:4 Changed 13 years ago by Sergey

both alpha & beta do not work. considering libc61: I have

Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20060531 SeaMonkey?/1.5a it uses 061 libc and news, in it, work fine.

So looks like its psi err/feature...

comment:5 Changed 13 years ago by dmik

Sergey, please tell me whether chat works when you set Proxy to Socks5 in the Connection settigs. Do you mean that Psi (with Proxy:None) doesn't connect to a jabber server that matches the 'direct' rule of your socks.cfg when the socks client is enabled or what?

What about the file transfer, it seems that Psi ignores any Proxy settings and always wants the direct connection by its design (need to look at the sources deeper in order to find that out). So in this case, this problem is not OS/2 specific. Unfortunately, I don't have so much time to enhance Psi itself so I cannot promice it will be fixed by me in the near feature.

comment:6 Changed 13 years ago by dmik

  • Description modified (diff)

comment:7 Changed 13 years ago by guest

sorry for delay.

Chat works fine when sock5 set in PSI settings. I meant that PSI doesnt connect to server (ex xmpp.ru), surely its beyond 'direct' connection addr space.

Its strange because, as I mentioned, Mozilla and Jeti successfuly use it.

comment:8 Changed 12 years ago by dmik

Well, now sorry for delay from my side :)

I still don't fully get what doesn't work for you exactly. What I understood is:

  1. You have OS/2 socks5 set up and running.
  2. socks5 is configured so that a packet to xmpp.ru (213.180.203.19) originated from your machine's interface is not sent directly but instead gets "tunneled" through the socks5 server (62.33.xx.xx).
  3. For some reason, you cannot login to xmpp.ru in the above scenario.

Is it correct?

Btw, what is the exact error message Psi shows when you cannot connect?

comment:9 Changed 12 years ago by dmik

  • Resolution set to wontfix
  • Status changed from new to closed

Closing this defect due to lack of the feedback from the reporter and impossibility to reproduce the problem.

Note: See TracTickets for help on using tickets.