Opened 10 years ago

Closed 7 weeks ago

#82 closed enhancement (fixed)

add support for wrc

Reported by: diver Owned by:
Priority: trivial Milestone:
Component: qmake Version: 4.5.1 Beta 2
Severity: highest Keywords:
Cc:

Description

adding support for wrc in qmake.

if emxomfld_rc_type=WRC then take wrc otherwise rc

Change History (5)

comment:1 Changed 10 years ago by dmik

The problem is that as opposed to the linker where the user can use either ilink or wlink on the same set of input files (.obj and .lib), the format of .rc files understood y RC.EXE and by WRC.EXE differs and is generally not interchangeable. This means that the same .rc file is not necessarily a valid input for both of them which means that simple switching of the executables will not work.

A better approach in this case will be to choose resource compilers per source rather than globally. This basically requires an extra qmake target for WRC-like .rc files. (I don't want to change the default resource compiler since RC.EXE is distributed separately and is usually preinstalled on many eCS systems while for WRC one needs to install the whole Watcom application).

We will provide a pre-defined extra target for WRC later. For now, one may create an extra target in its .pro file himself (search the Qt docs for how to create extra targets in qmake).

comment:2 Changed 5 years ago by komh

  • Severity set to highest

.rc format difference is not a problem if WRC is used only for QMAKE_RUN_RC2EXE. In addition, if EMXOMFLD_RC_TYPE is already WRC, no need to worry about the absence of WRC.

comment:3 Changed 14 months ago by diver

  • Milestone changed from Qt Enhanced to Qt 5

comment:4 Changed 7 weeks ago by diver

  • Milestone Qt 5 deleted

Ticket retargeted after milestone closed

comment:5 Changed 7 weeks ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in Qt 5. If not open a ticket at https://github.com/bitwiseworks/qtbase-os2

Note: See TracTickets for help on using tickets.