Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#282 closed defect (fixed)

QDIR problem

Reported by: diver Owned by:
Priority: major Milestone: Qt 4.7.3 GA2
Component: General Version: 4.7.3
Severity: low Keywords:
Cc:

Description

QDIR(/@unixroot/usr/lib) produces e:/@unixroot/usr/lib when a app runs from drive e.
in the unixroot case i guess this is wrong.

Change History (6)

comment:1 Changed 7 years ago by diver

  • Milestone changed from Qt Enhanced to Qt 4.next

comment:2 Changed 7 years ago by dmik

The problem is fixed by manually performing kLIBC path rewrite in the OS/2 file engine code when calculating absolute paths. See r1112 for details.

Silvan, please check it with your apps, it should work now. Also please perform as many Qt tests as possible to make sure this change doesn't break anything (it shouldn't).

Note also that the proper solution is (IMHO) to fix the kLIBC's _abspath() call itself instead of doing this in Qt (or any other app). I will create a respective kLIBC ticket for discussing that.

comment:3 Changed 7 years ago by diver

i did some tests and could not see any problems

comment:4 Changed 7 years ago by dmik

  • Milestone changed from Qt 4.next to Qt 4.7.3 GA2

comment:5 Changed 7 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Good, closing (my tests within #267 also prove that as the certificate files use path rewrite).

comment:6 Changed 7 years ago by dmik

I also created http://svn.netlabs.org/libc/ticket/267 for the _abspath() fix.

Note: See TracTickets for help on using tickets.