Opened 8 years ago

Closed 7 years ago

#268 closed defect (invalid)

file selection doesn't always work

Reported by: guzzi Owned by:
Priority: Feedback Pending Milestone: Qt Enhanced
Component: General Version: 4.7.3
Severity: low Keywords:
Cc:

Description

Not sure if this is the proper place to report this...
See tickets:
http://svn.netlabs.org/qtapps/ticket/27
http://svn.netlabs.org/qtapps/ticket/28

I remember the same thing as in http://svn.netlabs.org/qtapps/ticket/28 happened with some earlier versions of smplayer, although in smplayer it has been fixed.

Attachments (2)

qmetrofs.jpg (42.0 KB) - added by guzzi 8 years ago.
Qmetro.png (23.8 KB) - added by Tellie 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by rudi

What do you mean with "doesn't always work" ?

The second part of http://svn.netlabs.org/qtapps/ticket/27 is definitively a bug in the application code (file: paternEditor.cpp, lines: 49..52) and http://svn.netlabs.org/qtapps/ticket/28 is not reproducable here.

Changed 8 years ago by guzzi

comment:2 Changed 8 years ago by guzzi

I have forwarded your comment on ticket 27 to the developer. Re. ticket 28, I attached a screenshot.

comment:3 Changed 8 years ago by rudi

Hmm, in your screenshot the "Look in" combo box does not contain a drive letter. Here it does. Could you please check, if the directories:

\APPS
\APPS\QMETRO
\APPS\QMETRO\BIN
\APPS\QMETRO\BIN\map

have extended attributes ? You can do that by running "dir <dir_name>" from a command line and see if the "." entry has a nonzero EA size.

comment:4 follow-up: Changed 8 years ago by guzzi

\APPS has extended attribs
The others have not.
What is the consequence of this?

comment:5 Changed 8 years ago by guzzi

The ea's are:
.classinfo
.iconpos

Changed 8 years ago by Tellie

comment:6 Changed 8 years ago by Tellie

It's not reproducable here to.
For me works ok.

comment:7 in reply to: ↑ 4 Changed 8 years ago by rudi

Replying to guzzi:

\APPS has extended attribs The others have not. What is the consequence of this?

I'm asking beacuse LIBC stores permission information in EAs and we have seen a situation, where a directory with invalid permissions caused strange behavior. But the attribs you mention are created by the WPS, not LIBC.

comment:8 Changed 8 years ago by rudi

It maybe worth a try to remove the file %HOME%\.config\Trolltech.ini. Besides the list of plugins it also stores global settings for the file dialog. Maybe something got messed up there...

comment:9 Changed 8 years ago by guzzi

Removing trolltech.ini didn't make a difference. I tested some more qt apps. Qeven and focuswriter show the same behaviour, while smplayer does display the driveletter in the file open dialog.

I noticed that with focuswriter the whole f:\home\default path showed for a fraction of a second, then got replaced by just home\default......

comment:10 Changed 8 years ago by rudi

Hmm, could that be caused by the libc pathrewriter ? I don't have it installed here...

comment:11 Changed 8 years ago by guzzi

I do have it installed. Will uninstall and see if it makes a difference. What exactly is it used for and what might be the consequences of removing it for various software?

comment:12 Changed 8 years ago by guzzi

Removing klibccfg.dll didn't make a difference.

comment:13 Changed 8 years ago by diver

  • Priority changed from major to Feedback Pending

what libc version do you have installed? only libc064 or libc064 and the libc063.dll from the libc063 package?

comment:14 Changed 7 years ago by diver

  • Resolution set to invalid
  • Status changed from new to closed

it seems the reporter lost interest, as since 7 month no feedback. so closing it.

Note: See TracTickets for help on using tickets.