Opened 9 years ago

Closed 9 years ago

#192 closed defect (fixed)

qt-lib-4_6_3-noxwpdep.wpi broken

Reported by: rudi Owned by:
Priority: major Milestone: Qt 4.7
Component: General Version:
Severity: highest Keywords:
Cc:

Description

The packages 1 ("Installation Utilities") and 2 ("Runtime") are swapped, resulting in an nonfunctional installation.

Change History (6)

comment:1 Changed 9 years ago by rudi

The bug is in Makefile.packages, lines 105 and 106

comment:2 Changed 9 years ago by rudi

Another note: The WiKi? start page lists "MySQL Runtime" and "PostgresSQL Runtime" as neccessary to run the plugins. This is not true. Our database plugins only require the OpenSSL runtime. So the clients don't need any MySQL or PostgresSQL DLLs and therfore also no kLIBC0.6.4.

comment:3 Changed 9 years ago by diver

  • Milestone changed from Qt Enhanced to Qt 4.7

hmm i read the page, but could not see where you found that. doesn't it say optional?

comment:4 Changed 9 years ago by rudi

It says "necessary for the xxxSQL plugin". For me that implies, that these packages are required to run the plugin. The "optional" for me means, that I don't need them if I don't intend use these plugins.

But what we really want to say is that these packages are needed to build the plugin. Thus I find it misleading to mention them as "Prerequisites".

comment:5 Changed 9 years ago by dmik

Rudi, thanks for testing!

All is fixed now.

Note that I re-created and re-uploaded all packages because I bumped the build number in WPIs (the full WPI version is 4.6.3.834 now), for clarity. The Wiki mentions this update too.

comment:6 Changed 9 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.