Opened 10 years ago

Closed 10 years ago

#186 closed defect (fixed)

quassel eats cursor

Reported by: Silvan Scherrer Owned by:
Priority: major Milestone: Qt 4.6.3
Component: General Version: 4.6.2
Severity: low Keywords:
Cc:

Description

when you minimize quassel via the systray icon and then restore it, the cursor is not available anymore. if you switch out and in again the cursor if available again.

Change History (2)

comment:1 Changed 10 years ago by Dmitry A. Kuminov

Fixed in r807. The bug has been always there BTW. It turned out to be a Windows bug that I copied over. In Qt4, they changed the windowFlags() bitfield assignment, so that in order to test for a Popup window, you have to do (widget->windowFlags() & Qt::Popup) == Qt::Popup instead of just (widget->windowFlags() & Qt::Popup)}}} because Qt::Popup is a combined flag now.

SHHHHIIIIIIIIT! Completely brainless commit UI in Slickedit, they must have written it with eyes closed and never used themselves. Empty commit message again. I made thousands of commits with SVN and only two of them didn't have a message, both are from Slickedit. ERRRRRRRR. RRRRRRRRRRRRRRRRR. The message should be:

gui: Fixed: Hiding the main application window programmatically with QWidget::hide() and then showing it again with QWidget::show() would not activate it from the Qt point of view which prevented the child widgets from getting the keyboard focus (and input).

BTW, I finally installed HPFS386 instead of HPFS to both my OS/2 machines today, and the performance boost is really impressive: the builds go 3 to 5 times faster now! I really wonder how long will it take to make a full release build in this setup (which previously took 13-14 hours). But I will try JFS first and compare the results with HPFS386.

comment:2 Changed 10 years ago by Silvan Scherrer

Resolution: fixed
Status: newclosed

ok i can confirm it works now again.

Note: See TracTickets for help on using tickets.