Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#173 closed defect (fixed)

Arora drawing problem while dragging

Reported by: rudi Owned by:
Priority: major Milestone: Qt 4.6.3
Component: QtGui Version: 4.6.2
Severity: low Keywords:
Cc:

Description

The Arora browser allows a bookmark to be dragged out of the "History" menu using the left mouse button. On OS/2 this will cause a screen update error. This happens in in both DIVE and GPI modes.

I noticed an interresting difference in behaviour between OS/2 and Windows: While in Windows the menu stays open until the item is dropped, in OS/2 it closes immediately when the drag begins. It looks like this is part of the problem...

Change History (11)

comment:1 Changed 4 years ago by rudi

  • Component changed from General to QtGui

comment:2 Changed 4 years ago by dmik

  • Milestone changed from Qt Enhanced to Qt 4.6.3

comment:3 Changed 4 years ago by dmik

Can you please provide an Arora source drop that shows this behavior?

comment:4 Changed 4 years ago by rudi

You can grab the source here:

http://telefon.s-t.de/rudi/aurora_0_10_2.zip

Just run qmake and make [Debug/Release?]. Note: there is a fix for a little sloppyness of the original source in src\network\networkaccessmanager.h, which is unneccessary, when compiled with SSL support...

comment:5 Changed 4 years ago by dmik

Confirm the update error. Regarding the differences with the Windows behavior. Interesting what is the expected one -- for me, closing the menu right after dragging begins sounds more reasonable since you may want to drop it somewhere under the menu, for example.

Anyway, will look at it little bit later.

comment:6 Changed 4 years ago by rudi

you may want to drop it somewhere under the menu, for example.

I think the idea is to drop it on the menu (to change item order).

comment:7 Changed 4 years ago by dmik

I don't think so. At least, dragging it on Windows doesn't cause the menu items to rearrange.

comment:8 Changed 4 years ago by rudi

dragging it on Windows doesn't cause the menu items to rearrange

Strange, here it does. Even though it's broken since it sometimes/often leads to duplication of menu items.

comment:9 Changed 4 years ago by dmik

Yes, I got this broken behavior on Windows here. It looks like the items in the bookmarks menu replace the ones underneath instead of being inserted in the middle when you drag and drop them.

Back to the topic. All popup menus are dismissed once we enter DrgDrag?(). I will check the drag message handlers to find who's responsible. I hope it's not some internal PM behavior because we're in trouble in this case.

comment:10 Changed 4 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

The problem is fixed in r785. Now we get the behavior identical to the Windows version.

comment:11 Changed 4 years ago by dmik

Fixed one more DnD repaint screen corruption bug in r786 that could be sometimes seen when dragging the bookmark item out of the popup menu in DIVE mode.

Note: See TracTickets for help on using tickets.