Opened 4 years ago

Closed 4 years ago

#128 closed defect (fixed)

"lib" WPI package doesn't install on systems with no XWorkplace installed

Reported by: dmik Owned by:
Priority: minor Milestone: Qt 4.6.2
Component: General Version: 4.5.1 GA
Severity: very low Keywords:
Cc:

Description

If you try to install the lib package on a system that doesn't have XWorkplace installed, it will fail as described here.

Change History (6)

comment:1 Changed 4 years ago by dmik

The problem is that we refer to the XWorkplace installation path for the XCenter SysTray? plugin which WarpIn? tries to resolve regardless of whether the SysTray? plugin is selected for installation or not.

Paul Ratcliffe confirmed that it's a WarpIn? bug. It may take some time to fix and I can actually try to overcome this bug with REXX in the meanwhile.

comment:2 Changed 4 years ago by dmik

Okay, as usual, a initially trivial task turns out to be an extremely complex on practice. The problem this time is that there is a mess with encodings in WPI. The .wis files are expected in the system encoding while it seems that the package database stores strings in UTF-8. But retrieving such a string using REXX (which assumes local encoding too) and then comparing it to the absolutely same UTF-8 string returns false for some strange reason...

comment:3 Changed 4 years ago by herwigb

Using WPIView from http://members.aon.at/herwig.bauernfeind/os2.html in order to unpack the Qt packages will workaround this problem

comment:4 Changed 4 years ago by dmik

Should have been fixed in r546. The package has been uploaded as ftp://ftp.netlabs.org/pub/qt4/4.5.1-ga/qt-lib-4_5_1-ga-noxwpdep.wpi. Asked the user to test.

comment:5 Changed 4 years ago by dmik

  • Priority changed from major to minor
  • Severity changed from low to very low

comment:6 Changed 4 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

The user reports that the new WPI works with no XWorkplace/XCenter installed. I updated the Wiki to point to the new WPI.

Note: See TracTickets for help on using tickets.