Opened 5 years ago

Closed 5 years ago

#106 closed defect (invalid)

Crash in PMMERGE

Reported by: diver Owned by:
Priority: major Milestone: Qt Beta 5
Component: QtGui Version: 4.5.1 Beta 3
Severity: Keywords:
Cc:

Description

when doing the following smplayer crashes in PMMERGE

-executing smplayer
-running a movie
-stop the movie
-preferences , advanced, run mplayer in own window (add checkmark)
-running a movie
-stop the movie
-preferences, advanced , run mplayer in own window (remove checkmark)
-running a movie

now smplayer crashes while resizing itself

Change History (6)

comment:1 Changed 5 years ago by diver

i debuged it a bit further. and in basegui.cpp of smplayer i added a qDebug() right before a resize() function line 3987. and i see that debug still. but resize() crashes then, as i see no more qDebug() after it.

comment:2 Changed 5 years ago by dmik

Did as you described and cannot reproduce the crash so far. I even tried to make the SMPlayer window very small to make sure that when I switch MPlayer back to it, it gets resized. And I also tried to resize the SMPlayer window itself while playing a movie in it -- still no luck to catch a crash.

comment:3 Changed 5 years ago by dmik

Also tried the release build, just in case -- doesn't crash as well. Maybe you have some specific setting activated that affects this...

comment:4 Changed 5 years ago by diver

i almost feared that, as one of my testers can't reproduce it also. could it be a graphic driver issue?

comment:5 Changed 5 years ago by dmik

In theory -- yes. Please try to qDebug() it more. We need a place where the recursion starts. I suggest that you uncomment QT_DEBUGMSGFLOW in qapplication_pm.cpp to log every PM message Qt gets (well, to actually see all messages you should also comment out #if 0 at #2387 too).

comment:6 Changed 5 years ago by diver

  • Resolution set to invalid
  • Status changed from new to closed

i installed snap in vesa mode and in this mode there is no crash. so it looks like a panorama thinggy. will reopen it, if i still can reproduce it with snap.

Note: See TracTickets for help on using tickets.