Opened 2 years ago

Closed 2 years ago

#60 closed defect (fixed)

Java 1.6 issues related to ODIN build 0.81

Reported by: gerrit Owned by:
Priority: Feedback Pending Milestone: 0.8.3
Component: odin Version:
Severity: high Keywords: Java 1.6; Odin 0.81
Cc:

Description

Hello,

I'm using "iTrain" (berros.eu/itrain) and JAVA 1.6 GA for eComStation 2.1 to run my model railroad layout. With ODIN 0.71 and the JAVA 1.6 so far so good. However by switching from ODIN 0.71 to the latest GCC build 0.81 my Java application iTrain became unstable and crashes all the time when either open pull down menu's or drag and drop was used to change settings.

Change History (4)

comment:1 Changed 2 years ago by abwillis

Hmm, I wonder if this is related to ticket #58 as the symptoms are similar... if so then it would certainly validate Dmitry's assessment that it could in theory affect all apps.

comment:2 Changed 2 years ago by dmik

The crash during drag&drop was a different issue, I fixed it in r21928 and r21929. The test build is at ftp://ftp.netlabs.org/pub/odin/test/o21929.zip. Please try and tell if all problems are gone.

I can't reproduce any crash here at least.

comment:3 Changed 2 years ago by diver

  • Priority changed from major to Feedback Pending

please take latest 0.8.2 and retry it.

comment:4 Changed 2 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

Gerrit just said via e-mail that it works now. so i close this ticket.

Note: See TracTickets for help on using tickets.