Line | |
---|
1 | Summary: fast lexical analyzer generator
|
---|
2 | Name: flex
|
---|
3 | Version: 2.5.33
|
---|
4 | Release: 0
|
---|
5 | License: BSD style
|
---|
6 | Group: Development/Tools
|
---|
7 | Source: ftp://ftp.ee.lbl.gov/%{name}-%{version}.tar.gz
|
---|
8 | Prefix: %{_prefix}
|
---|
9 | BuildRoot: %{_tmppath}/%{name}-%{version}
|
---|
10 | Prereq: /sbin/install-info
|
---|
11 |
|
---|
12 | %description
|
---|
13 | The flex program generates scanners. Scanners are programs which can
|
---|
14 | recognize lexical patterns in text. Flex takes pairs of regular
|
---|
15 | expressions and C code as input and generates a C source file as
|
---|
16 | output. The output file is compiled and linked with a library to
|
---|
17 | produce an executable. The executable searches through its input for
|
---|
18 | occurrences of the regular expressions. When a match is found, it
|
---|
19 | executes the corresponding C code. Flex was designed to work with
|
---|
20 | both Yacc and Bison, and is used by many programs as part of their
|
---|
21 | build process.
|
---|
22 |
|
---|
23 | %prep
|
---|
24 | %setup -q -n %{name}-%{version}
|
---|
25 |
|
---|
26 | %build
|
---|
27 | %configure
|
---|
28 | make
|
---|
29 |
|
---|
30 | %install
|
---|
31 | rm -rf $RPM_BUILD_ROOT
|
---|
32 | %makeinstall
|
---|
33 | rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
|
---|
34 |
|
---|
35 | %clean
|
---|
36 | rm -rf ${RPM_BUILD_ROOT}
|
---|
37 |
|
---|
38 | %post
|
---|
39 | /sbin/install-info %{_infodir}/flex.info.gz %{_infodir}/dir
|
---|
40 |
|
---|
41 | %postun
|
---|
42 | if [ "$1" = 0 ]; then
|
---|
43 | /sbin/install-info --del %{_infodir}/flex.info.gz %{_infodir}/dir
|
---|
44 | fi
|
---|
45 |
|
---|
46 | %files
|
---|
47 | %defattr(-,root,root)
|
---|
48 | %doc COPYING NEWS README
|
---|
49 | %{_bindir}/*
|
---|
50 | %{_mandir}/man1/*
|
---|
51 | %{_libdir}/*
|
---|
52 | %{_includedir}/FlexLexer.h
|
---|
53 | %{_infodir}/flex.info*
|
---|
54 | %{_datadir}/locale/*
|
---|
Note:
See
TracBrowser
for help on using the repository browser.