Opened 3 years ago

Last modified 3 years ago

#132 new defect

"DSO missing from command line" error on bootstrap

Reported by: habs Owned by:
Priority: minor Milestone:
Component: kBuild Version: 0.1.5
Keywords: bootstrap Cc: habs@…

Description

I was running an up-to-date GuixSD and trying to bootstrap kBuild 0.1.5-p2 "Sources and everything" edition using these directions: http://trac.netlabs.org/kbuild/wiki/Bootstrapping

But when I run export KBUILD_PATH=/home/habs/builds/kBuild-0.1.5-p2/kBuild/; kBuild/env.sh --full make -f bootstrap.gmk from the kBuild-0.1.5-p2 directory, I get this (abbreviated) error at the "kBuild: Linking kmk_append" step:

ld: incdep.o: undefined reference to symbol 'pthread_create@@GLIBC_2.2.5'
libpthread.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

Here is the more complete relevant portion of the output: http://sprunge.us/GjjY

What can I do to fix this? I've tried running the command as kBuild/env.sh --full make CFLAGS='-lpthread' -f bootstrap.gmk, but it didn't yield any different results.

Attachments (1)

output.txt (9.9 KB) - added by habs 3 years ago.
kBuild bootstrap error output (relevant section only)

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by habs

kBuild bootstrap error output (relevant section only)

comment:1 Changed 3 years ago by habs

  • Cc habs@… added
Note: See TracTickets for help on using tickets.