Opened 9 years ago

Closed 9 years ago

#44 closed defect (fixed)

SMP: System hangs on closing java app

Reported by: losepete Owned by:
Priority: blocker Milestone: GA
Component: general Version: 1.6.0-b19 Beta
Severity: low Keywords:
Cc:

Description

I've only tried using Version 1.6.0 Build 19 Beta (2010-12-30) to run a java game Sudoku - v0.9.12 of freesudoku, freesudoku.sourceforge.net - 3 times.

On every occassion the game plays fine *but* when exiting the game the system hangs and it is not possible to "kill" javaw.exe using TOP.

I also had 1 crash on exit which produced a log. I attach the log as hs_err_pid106.log

Attachments (1)

hs_err_pid106.log (1.7 KB) - added by losepete 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by losepete

comment:1 follow-up: Changed 9 years ago by dmik

What OS/2 version do you use and what kernel? SMP is not supported ATM and gives exactly the same behavior as you describe.

comment:2 in reply to: ↑ 1 Changed 9 years ago by losepete

Replying to dmik:

What OS/2 version do you use and what kernel? SMP is not supported ATM and gives exactly the same behavior as you describe.

Using eCS2.0GA with kernel @#IBM:14.104a#@_SMP

Guess I'll wait for a later release with SMP support

comment:3 Changed 9 years ago by diver

the smp problem is known. we try to solve that while doing java development. it's a common odin problem.

see also http://svn.netlabs.org/odin32/ticket/28 for progress an that

comment:4 Changed 9 years ago by dmik

  • Milestone set to GA
  • Priority changed from major to blocker
  • Summary changed from system hangs on closing java app to SMP: System hangs on closing java app
  • Version set to 1.6.0-b19 Beta

comment:5 Changed 9 years ago by dmik

  • Milestone changed from RC to GA

comment:6 Changed 9 years ago by dmik

  • Milestone changed from RC2 to GA
  • Severity set to low

comment:7 Changed 9 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

The issue is fixed in Odin (http://svn.netlabs.org/odin32/ticket/28).

Note: See TracTickets for help on using tickets.