Opened 9 years ago

Closed 8 years ago

#43 closed task (wontfix)

Testing eCS Java 6 (1.6 beta) with a swing intensive application like iTrain

Reported by: gerritsch Owned by:
Priority: Feedback Pending Milestone: Enhanced
Component: general Version:
Severity: low Keywords: Swing, AWT, serial port support
Cc:

Description

I'm running my modeltrains with the in Java written program iTrain (http://www.berros.eu/itrain/download/preview/iTrain_install.jar). So I was very curious to see if it would run on eCS. Just tested the 1.6 JRE beta with the latest Beta version 2.0.0-b44 of iTrain (build 2011/01/02). Here are some results:

  1. Installation of iTrain runs fine, except the progress bars, they were empty and therefore nothing visible happened.
  2. iTrain is coming with two special Java DLL's for serial port support (JSPOS2J.DLL and SCCOMIO.DLL) for OS/2. Still there is no serial port connection possible. Both DLL's were put in the /JRE/bin directory and Java 1.6 crashed as soon as in the iTrain application the menu to check the serial interface was opened. Below you will find the output of the commandline during the crash:

OpenJDK Client VM (build 16.0-b13, mixed mode)

[D:\Programs\ITRAIN2TEST]java -jar D:\Programs\iTrain2test\itrain.jar
Serialio Library: version 9.9.9: build 9193
Copyright (c) 1996-2008 Serialio.com, All Rights Reserved.
os.name="OS/2", os.arch="x86"
SerialPort? class loaded: jspos2j
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x10cce647, pid=1140, tid=74711
056
#
# JRE version: 6.0
# Java VM: OpenJDK Client VM (16.0-b13 mixed mode os2-x86 )
# Problematic frame:
# V [JVM+0x25e647]
#
# An error report file with more information is saved as:
# C:\var\temp\hs_err_pid1140.log
SYS1808:
The process has stopped. The software diagnostic
code (exception code) is 001E.

  1. iTrain is a heavy swing application. On the eCS 2.0 platform with Java 1.6 beta no "drag and drop" was possible within the iTrain application (e.g. it should be possible to drag a locomotive from the loc list to the throttle window, see also attached screenshot). Furthermore some context menu's disappear as soon as they were tried to open.

These are my first impressions with Java 1.6 beta for OS/2 & eCS tested on a T42 IBM Thinkpad


Attachments (2)

hs_err_pid1140.log (1.7 KB) - added by gerritsch 9 years ago.
error log
iTrain_on_eCS.jpg (139.1 KB) - added by gerritsch 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by gerritsch

error log

Changed 9 years ago by gerritsch

comment:1 Changed 9 years ago by gerritsch

  • Type changed from defect to task

comment:2 Changed 9 years ago by jojo

Seems that the serial port driver stems from: http://www.serialio.com/products/serialport/packages.php and is embedded in the itrain application.

The serial port communication is not required in order to use this app, the most important problem is the lack of drag & drop.

Regards,

Joachim

comment:3 Changed 9 years ago by dmik

I tried to install this application and see several problems with the installer:

  1. It doesn't show the license files to me (just empty text boxes).
  2. It cannot create an installation directory.

Note that the problem 2 I also saw with the jEdit installer. I will look into them first.

comment:4 Changed 9 years ago by dmik

And there is indeed some problem with DND. I can see it in the Notepad.jar demo application (when dragging the text). Created #45 for the DnD issue and #46 for the directory problem.

comment:5 Changed 9 years ago by dmik

BTW, I fixed #46 and installed iTrain using its installer and in my case progress bars work just well. I actually wonder how you could install iTrain with its installer at all with Beta as it should have failed when creating the installation directory.

comment:6 Changed 9 years ago by dmik

Regarding the DLLs. Do you know what Java version these DLLs were originally written for? There may be a difference between the OS/2 JNI and WIN32OS2 (Odinized) JNI that makes them incompatible... I will check that later.

comment:7 Changed 8 years ago by diver

  • Priority changed from critical to Feedback Pending
  • Severity set to low

comment:8 Changed 8 years ago by dmik

  • Resolution set to wontfix
  • Status changed from new to closed

The problem with DLLs seems to be similar to the one we see in #49. We can't do much here w/o getting the source codes of these DLLs. And anyway this is beyond the original topic of this report (which is resolved now as iTrain works quite well besides the serial communication DLL).

If you find more details about the DLL (sources etc.) feel free to open a new ticket and we will look at it.

Note: See TracTickets for help on using tickets.