Opened 7 years ago

Last modified 6 years ago

#213 new defect

Java crashes eCS 2.1

Reported by: oara27 Owned by:
Priority: major Milestone: Enhanced
Component: general Version: 1.6.0 Build 27 GA5
Severity: medium Keywords:
Cc:

Description

First thing after booting, I started and then closed Firefox (10.0.12).

Then I tried to run TightVNC 2.6.2 Java app (get it here
http://www.tightvnc.com/download.php)
Although it used to run with eCS Java GA 4 and older, it has not been working well with GA5. Now it wouldn't open past the login screen. My desktop was frozen, the cursor became the VNC remote desktop point cursor.

I used the C-A-D popup's TOP app to kill the Java process.

After returning to my working desktop, I opened Firefox again to come to this page, to look for Java updates. At the same time I tried to check the Java -version in a 4OS2 window.

The system immediately crashed to a black screen. NO messages in POPUPLOG.OS2. Rebooting required chkdsk on all my HPFS and JFS drives.

After the reboot, I reproduced the issue with the VNC desktop, and the need to kill the JAVA process with TOP. I had also increased the virtual address limit from 1 GB to 2 GB, to see if it would help, no dice.

My system is a 4GB RAM with 4-cores AMD Phenom II, 500 GB HDD, XFX AMD 1GB video.

I run eCS 2.1 with Odin 0.8.9, Java GA5 (of course).

Since JAVA is already at v. 7.17 for all other OS's, and all older Java versions are VERY unsafe, what is the prospect for a proper working, safe Java for eCS? Given that eCS is well outside the mainstream of OS's in browsers, media players, office apps, etc., incremental approaches releasing successive older versions of Java won't work. If it is not possible to proceed directly to the latest Java, isn't this the end of the road for OS/2-eCS?

Attachments (2)

hs_err_pid76.log (22.6 KB) - added by oara27 7 years ago.
tightvnc 2.6.2 crash log with GA3
java-crash-netlabs.txt (45 bytes) - added by oara27 7 years ago.
tightvnc 2.6.2 error message with GA3

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by oara27

tightvnc 2.6.2 crash log with GA3

comment:1 Changed 7 years ago by oara27

Regressing to GA3 I managed to collect a crash log and error message. But no logs for GA4 or GA5 crashes yet.

Changed 7 years ago by oara27

tightvnc 2.6.2 error message with GA3

comment:2 Changed 6 years ago by jep

Same problem as mine:
AMD Phenom <--- AMD specific instruction set?
SMP, 4 cores enabled <--- SMP issue?

eCS 2.1 and eCS 2.2 <--- Doesn't matter
GenealogyJ <--- Doesn't matter
JDownloader 0.9x <--- Doesn't matter
JDownloader 2 <--- Doesn't matter

Last edited 6 years ago by jep (previous) (diff)

comment:3 Changed 6 years ago by gap

I have to take exception with the comments about end of the road.

I have been using IBM Java 1.3 for production work for years without any problems.
All the applications are developed by me at Corvedia Inc. There are not any security issues.
These applications are secure communications using proprietary technology.
Any security issues that might exist would relate to web browsing.
In a server application the Java from IBM is rock solid.

There are features of Java 1.6 which would be nice. Such as file sizes > 2 gig.
Please take a pill and calm down.

comment:4 Changed 6 years ago by oara27

comments for jep:
I tried

  • running with just a single core (ACPI 3.21.7.0 commented out)
  • changing java.exe from mp to sp mode, with execmode.

Result: exactly same issue. And I just can't believe that the AMD instruction set would play any role, since it works just fine with all other eCS apps, and on all other platforms.

In any case, I don't see the point of having multicore CPU's to operate them in single processor mode.

comment for gap:

the point of Java is to run any java app on any platform that supports java, not proprietary apps on private installations. The apps I need/want to run, don't run under java 1.3. Unless you or someone else comes up with a free Java vnc desktop emulator that runs on Java 1.3, (this also applies to many other apps or in-browser applets,) comments such as "taking pills and calming down" make no sense. Any OS that cannot keep up with the times won't last.

Last edited 6 years ago by oara27 (previous) (diff)
Note: See TracTickets for help on using tickets.