Opened 7 years ago

Closed 7 years ago

#179 closed defect (fixed)

AOO hangs when using new SEH scheme

Reported by: dmik Owned by:
Priority: major Milestone: GA4
Component: general Version: 1.6.0 Build 25 GA3
Severity: medium Keywords:
Cc:

Description

Seems that there is one more victim of the new SEH scheme - AOO. Java works in AOO (Apache OpenOffice?) if I use GA2 (old SEH scheme) and hangs (with a crash in ODINCDT.DLL) if I use GA3. Here's the POPUPLOG:

07-27-2012  14:41:30  SYS3170  PID 00e9  TID 0001  Slot 00c1
D:\APPS\OPENOFFICE.ORG.3\PROGRAM\SOFFICE.BIN
c0010002
118d00e2
P1=00000000  P2=XXXXXXXX  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=168d6514  ECX=00000000  EDX=de4a9dc7
ESI=168d6514  EDI=168d6440  
DS=0053  DSACC=d0f3  DSLIM=5fffffff  
ES=0053  ESACC=d0f3  ESLIM=5fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1c3d07c9  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:0012fe80  SSACC=d0f3  SSLIM=5fffffff
EBP=0012fe98  FLG=00010213

ODINCRT.DLL 0002:000000e2

Change History (2)

comment:1 Changed 7 years ago by dmik

Okay, I found the reason. It's because when JVM.DLL is loaded directly in which case WinMain? is not executed and the "switch Win32<->OS2 FS" mode is ON (by default). If I set it to OFF by default, all works fine. Before committing, I need to look why it crashes. It shouldn't.

comment:2 Changed 7 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

The problem is fixed by closing http://svn.netlabs.org/odin32/ticket/83. Note that it means that we will need to release a new version of Odin with GA4.

Note: See TracTickets for help on using tickets.