Opened 14 years ago

Closed 12 years ago

#58 closed defect (fixed)

System hangs when serially opening multiple files for viewing from an archive

Reported by: Gregg Young Owned by: Steven Levine
Priority: minor Milestone: Release_3.14
Component: fm/2 base Version:
Keywords: hang Cc:

Description

Steven

I now am seeing a slightly different hang using the beta 6. It seems to happen when I serially open several files from an archive I am viewing. For example I open the ACPI archive then view the ACPI.doc close it then view ACPISMP.doc close it then try to view any other of the doc files the archive (unzip) window opens and will hang with the window title reading closing unzip. I can't get to CADPOP but if I hit CAD multiple times the machine reboots. Just before the reboot WPS & FM2 unfreeze and start to complete the operation. Unfortunately, this is very intermittent and I haven't been able to create a test case. There is no popup log entry. Thanks

Gregg

I saw this again this morning only this time it occurred when I opened an archive containing one small file. It opened but the system immediately became non responsive. Same result as above. The archive file work fine after the reboot.

I have also noticed that it occurs while I am scrolling with a wheel mouse using the amouse driver. I remember that at one point I was able to scroll off the end of the internal viewer because of the specific call that amouse makes for scrolling. Is it possible this hang is related. Again this is not reproducible but occurs occasionally.

Gregg

Change History (17)

comment:1 Changed 14 years ago by Gregg Young

The second part above seems to have been fixed by changing dossleep(0) to dossleep(1) in the threads.

The hang has occurred both with hyperview (resident in memory mode) and FTE.

comment:2 Changed 13 years ago by Steven Levine

Keywords: hang added
Milestone: Release_3.05_beta8
Owner: changed from StevenHL to Steven Levine
Status: newassigned

comment:3 Changed 13 years ago by Gregg Young

Resolution: fixed
Status: assignedclosed

comment:4 Changed 13 years ago by Gregg Young

Resolution: fixed
Status: closedreopened

comment:5 Changed 13 years ago by Steven Levine

Owner: changed from Steven Levine to Gregg Young
Status: reopenednew

comment:6 Changed 13 years ago by Steven Levine

Owner: changed from Gregg Young to stevenhl,gyoung

comment:7 Changed 13 years ago by Steven Levine

Owner: changed from stevenhl,gyoung to Steven Levine
Status: newassigned

comment:8 Changed 13 years ago by Gregg Young

Resolution: fixed
Status: assignedclosed

comment:9 Changed 13 years ago by Gregg Young

Resolution: fixed
Status: closedreopened

This reoccurred when the DosSleep? was reduced to 50 from 100. I have increased it back as a temporary fix. The race condition should be identified and addressed directly with a flag or semaphore.

comment:10 Changed 13 years ago by Gregg Young

Milestone: Release_3.5.8Release_3.8
Priority: criticalminor

comment:11 Changed 13 years ago by Gregg Young

Milestone: Release_3.8Release_3.9

comment:12 Changed 13 years ago by Gregg Young

Milestone: Release_3.9Release_3.10

comment:13 Changed 12 years ago by Gregg Young

Resolution: worksforme
Status: reopenedclosed

comment:14 Changed 12 years ago by Gregg Young

Resolution: worksforme
Status: closedreopened

comment:15 Changed 12 years ago by Steven Levine

Milestone: Release_3.12Release_3.13

comment:16 Changed 12 years ago by Gregg Young

Something is haning in the exit list in all likelihood.

comment:17 Changed 12 years ago by Gregg Young

Resolution: fixed
Status: reopenedclosed

Fixed CS 1270

Note: See TracTickets for help on using tickets.