Opened 13 years ago

Closed 11 years ago

#58 closed defect (fixed)

System hangs when serially opening multiple files for viewing from an archive

Reported by: gyoung Owned by: stevenhl
Priority: minor Milestone: Release_3.14
Component: fm/2 base Version:
Keywords: hang Cc:

Description

Steven

I now am seeing a slightly different hang using the beta 6. It seems to happen when I serially open several files from an archive I am viewing. For example I open the ACPI archive then view the ACPI.doc close it then view ACPISMP.doc close it then try to view any other of the doc files the archive (unzip) window opens and will hang with the window title reading closing unzip. I can't get to CADPOP but if I hit CAD multiple times the machine reboots. Just before the reboot WPS & FM2 unfreeze and start to complete the operation. Unfortunately, this is very intermittent and I haven't been able to create a test case. There is no popup log entry. Thanks

Gregg

I saw this again this morning only this time it occurred when I opened an archive containing one small file. It opened but the system immediately became non responsive. Same result as above. The archive file work fine after the reboot.

I have also noticed that it occurs while I am scrolling with a wheel mouse using the amouse driver. I remember that at one point I was able to scroll off the end of the internal viewer because of the specific call that amouse makes for scrolling. Is it possible this hang is related. Again this is not reproducible but occurs occasionally.

Gregg

Change History (17)

comment:1 Changed 13 years ago by gyoung

The second part above seems to have been fixed by changing dossleep(0) to dossleep(1) in the threads.

The hang has occurred both with hyperview (resident in memory mode) and FTE.

comment:2 Changed 13 years ago by stevenhl

  • Keywords hang added
  • Milestone set to Release_3.05_beta8
  • Owner changed from StevenHL to stevenhl
  • Status changed from new to assigned

comment:3 Changed 13 years ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 13 years ago by gyoung

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 13 years ago by stevenhl

  • Owner changed from stevenhl to gyoung
  • Status changed from reopened to new

comment:6 Changed 13 years ago by stevenhl

  • Owner changed from gyoung to stevenhl,gyoung

comment:7 Changed 13 years ago by stevenhl

  • Owner changed from stevenhl,gyoung to stevenhl
  • Status changed from new to assigned

comment:8 Changed 13 years ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:9 Changed 12 years ago by gyoung

  • Resolution fixed deleted
  • Status changed from closed to reopened

This reoccurred when the DosSleep? was reduced to 50 from 100. I have increased it back as a temporary fix. The race condition should be identified and addressed directly with a flag or semaphore.

comment:10 Changed 12 years ago by gyoung

  • Milestone changed from Release_3.5.8 to Release_3.8
  • Priority changed from critical to minor

comment:11 Changed 12 years ago by gyoung

  • Milestone changed from Release_3.8 to Release_3.9

comment:12 Changed 12 years ago by gyoung

  • Milestone changed from Release_3.9 to Release_3.10

comment:13 Changed 11 years ago by gyoung

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:14 Changed 11 years ago by gyoung

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:15 Changed 11 years ago by stevenhl

  • Milestone changed from Release_3.12 to Release_3.13

comment:16 Changed 11 years ago by gyoung

Something is haning in the exit list in all likelihood.

comment:17 Changed 11 years ago by gyoung

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed CS 1270

Note: See TracTickets for help on using tickets.